Contents

1. Introduction............................................................................................................................. 5
   1.1. Application Components Overview........................................................................... 7

2. Prerequisites........................................................................................................................... 9
   2.1. Constraints................................................................................................................ 9
   2.2. User Privileges......................................................................................................... 10
   2.3. Installation Checklist............................................................................................... 10

3. Installing SAP Business One .............................................................................................. 11
   3.1. Scenarios.................................................................................................................. 11
   3.2. Installing SAP Business One in Server-Client Mode............................................... 12
       3.2.1. Performing an SAP Business One Installation on Server Computers........... 12
       3.2.2. Performing SAP Business One Installations on Client Computers ............... 39
       3.2.3. Installing Integration Component for SAP Business One............................ 57
   3.3. Installing SAP Business One in Standalone Mode.................................................. 64
       3.3.1. Installing SAP Business One on One Computer ............................................. 64
   3.4. Installing SAP Business One in Remote Mode....................................................... 65
       3.4.1. Installing SAP Business One on a Remote Computer .................................. 65
       3.4.2. Performing a Client Installation..................................................................... 66
   3.5. Installing Crystal Reports for SAP Business One..................................................... 67
       3.5.1. Installing Crystal Reports 2008 SP01............................................................ 67
       3.5.2. Running the Crystal Reports Integration Package Script............................... 74
       3.5.3. Updates and Patches for Crystal Reports for SAP Business One................ 76
   3.6. Uninstalling SAP Business One................................................................................. 76
   3.7. Uninstalling Integration Component for SAP Business One..................................... 77

4. Performing Post-Installation Activities .............................................................................. 78
   4.1. Configuring Services ............................................................................................... 78
       4.1.1. SBO Backup.................................................................................................... 78
       4.1.2. SBO DI Server............................................................................................... 78
       4.1.3. License Manager............................................................................................ 79
       4.1.4. SBO Mailer..................................................................................................... 79
       4.1.5. Configuring the License Manager................................................................. 79
       4.1.6. Configuring the Fax Service.......................................................................... 81
       4.1.7. Configuring Backup Services....................................................................... 81
       4.1.8. Configuring SBO Mailer................................................................................. 85
   4.2. Technical Configurations........................................................................................... 92
   4.3. Installing the License Key........................................................................................ 92
   4.4. Assigning SAP Business One Add-Ons ................................................................... 94
       4.4.1. Constraints...................................................................................................... 96
5. Upgrading SAP Business One ............................................................................................ 97
   5.1. Upgrade Methods ....................................................................................................... 97
   5.2. Supported Releases for Upgrade ............................................................................... 98
   5.3. Upgrade Process ........................................................................................................ 99
      5.3.1. Downloading the Upgrade Package ................................................................... 100
      5.3.2. Running the SAP Business One Upgrade Wizard .......................................... 100
      5.3.3. Restoring Components and Databases ............................................................... 113
      5.3.4. Upgrading SAP Business One Client Workstations ....................................... 116
      5.3.5. Upgrading SAP Add-Ons .................................................................................. 119
      5.3.6. Upgrading the Online Help ............................................................................. 120
      5.3.7. Troubleshooting Upgrading SAP Business One with the Upgrade Wizard . 120
      5.3.8. Troubleshooting Upgrading Add-Ons .......................................................... 120
   5.4. Upgrading Directly from Upgrade Folders ................................................................ 121

6. Performing Database Maintenance Tasks ....................................................................... 122
   6.1. Database Server Administration ............................................................................... 122
      6.1.1. Starting and Stopping Database Services ................................................... 122
      6.1.2. Weekly Tasks ............................................................................................... 123
      6.1.3. Regular Tasks .............................................................................................. 124
      6.1.4. Backup ......................................................................................................... 126
      6.1.5. Restore ........................................................................................................ 130
   6.2. Data Transfer Workbench for SAP Business One ................................................... 134
   6.3. Stored Procedures .................................................................................................... 135
   6.4. Getting Support ......................................................................................................... 142
      6.4.1. Using Online Help and SAP Notes .............................................................. 143
      6.4.2. Using the Support Desk ............................................................................... 143

7. Managing Security in SAP Business One ........................................................................ 145
   7.1. Technical Landscape ............................................................................................... 145
   7.2. User Management and Authentication .................................................................... 146
      7.2.1. User Management ....................................................................................... 146
      7.2.2. User Authentication ...................................................................................... 150
   7.3. Database Authentication .......................................................................................... 151
   7.4. Data Integrity .......................................................................................................... 152
      7.4.1. Setting Read-Only User Permissions .......................................................... 152
      7.4.2. Registering New Databases in SAP Business One ..................................... 155
   7.5. SAP Business One Authentication and Authorization .............................................. 158
      7.5.1. Restricting Access to the SAP Business One Database ................................ 158
   7.6. Network Security ..................................................................................................... 158
      7.6.1. SSL Encryption ............................................................................................ 158
      7.6.2. Communication Channels ............................................................................ 159
   7.7. Application Security .................................................................................................. 159
7.7.1. Password Encryption ................................................................. 159
7.7.2. B1_SHR Folder Permissions ..................................................... 161
7.7.3. Query Generation and the Query Wizard ................................. 161
7.7.4. Add-On Access Protection ....................................................... 162
7.7.5. SAP Business One Dashboards ................................................. 162

7.8. Security Solutions for Microsoft SQL Server and Database Tips ........................................ 162
7.8.1. Upgrading the SQL Server ...................................................... 162
7.8.2. Steps to Securing Microsoft SQL Server ................................. 162
7.8.3. Revoking Guest Access to the msdb Database ......................... 162

7.9. Data Storage Security ................................................................. 163
7.9.1. Exporting Configuration Files ................................................. 163
7.9.2. Importing Configuration Files ............................................... 165
7.9.3. Configuration Logs and User Settings ..................................... 167

7.10. Troubleshooting Security ........................................................... 168

Copyrights, Trademarks, and Disclaimers ............................................ 170
1. Introduction

The Administrator's Guide for SAP Business One provides a central point for the technical implementation of SAP Business One. Use this guide for reference and instructions before and during the implementation project.

Note

This guide covers only the installation of SAP Business One and its add-ons.


For information about installing the Crystal Reports software, version for the SAP Business One application, see Installing Crystal Reports for SAP Business One.

Note

For the latest information about installation issues that may not appear in this guide, see SAP Note 1477279.

CAUTION

If you have the Crystal Reports integration add-on installed with any of the SAP Business One 2007 or 2005 releases, you must first uninstall the add-on before proceeding to the installation of the Crystal Reports software.

The Administrator's Guide consists of the following main sections:

- Prerequisites
  This section provides prerequisites to check before you proceed to the installation.

- Installing SAP Business One
  This section provides the process flow and instructions for installing and setting up SAP Business One and for removing the application.

  The three widely-used installation scenarios are introduced in this section. They are as follows:

  o Server-client installation
  o Standalone installation
  o Remote installation

- Performing Post-Installation Activities
  This section provides instructions for configuring the SAP Business One components after the installation.

  The activities include the following:

  o Configuring services
  o Assigning SAP add-ons
  o Installing Microsoft Outlook integration standalone version

- Upgrading SAP Business One
This section provides instructions for upgrading SAP Business One. You can use either of the following two methods to upgrade a previous installation of SAP Business One to SAP Business One 8.81:

- Upgrading with the SAP Business One upgrade wizard
  You can use the SAP Business One upgrade wizard to guide you through the upgrade process of the server components and the client files. After the wizard finishes successfully, you can log on to SAP Business One and upgrade with your client application workstation.

- Upgrading directly from the upgrade folders
  SAP Business One 8.81 also enables direct upgrading of some components from the upgrade folder files. This option is suggested for advanced users only.

**Note**
For more information about the upgrade package, see [Downloading the Upgrade Package](#).

- Performing Database Maintenance
  This section assists you with the following routine operations of SAP Business One and its database:
  - Database server administration, including the following:
    - Starting and stopping database services
    - Performing weekly tasks
    - Performing regular tasks
    - Performing backups
    - Performing restore functions
  - Working with Data Transfer Workbench
  - Getting Support
    Introduces the means by which you can get support from SAP. These include using the following:
    - SAP Business One online help documentation
    - SAP Notes
    - Support desk

- Managing Security in SAP Business One
  This section explains how to implement a security policy and provides recommendations for meeting the security demands of SAP Business One. As of SAP Business One 8.8, the use of more advanced encryption algorithms is supported.

  The logon process for end users is simplified, requiring authentication using SAP Business One user ID and password only.

To find out how to access other information about SAP Business One, see the Easy Start Guide on the product DVD.
1.1. Application Components Overview

This section includes a description of the important software components of SAP Business One and how they are used by SAP Business One's business processes.

SAP Business One is a client-server application and comprises the fat client and database server. The SAP Business One database only stores data and does not use triggers. However it does use views, especially for reporting and upgrade purposes.

The features and properties of SAP Business One server are as follows:

- One database server holds all company databases and the SBO-COMMON database. The company database is used to store all business data and transactional data. Customers can create several company databases. SBO-COMMON is the central database that holds system data, SAP Business One version information and upgrade information. SBO-COMMON does not store any business data.
- SAP Business One can run on Windows Terminal Services or Citrix Server and can run in several instances for different sessions.
- The license server can be on a different computer from the main server.

The server architecture is shown below in Figure 1.

---

Figure 1: SAP Business One Server Architecture

- Mandatory SAP Business One server components
  - License server of SAP Business One server tools
    The license server works with Microsoft SQL Server to maintain the user sessions and purchased licenses.
  - SAP Business One server
    Includes the database server with the SBO-COMMON database and company databases, as well as a server shared folder.
• Optional SAP Business One server components:
  o Other services of SAP Business One server tools
  o Server of remote support platform for SAP Business One
  o Microsoft Outlook Integration Server Add-On

The SAP Business One client is basically the application executable. The client computer holds SDK components used by add-on solutions.

• Data interface: a COM-based API and an applicative dll (OBSever.dll) file that enables add-ons to access and use SAP Business One business objects.

• UI interface: a COM-based API which is connected to the running application and enables add-ons to perform runtime manipulation and enhancement of the SAP Business One GUI and its flow.

The client architecture is shown below in Figure 2.

Figure 2: SAP Business One Client Architecture
2. Prerequisites

- For information on hardware and software requirements, refer to http://channel.sap.com/sbo/platforms.

- If you already have the Crystal Reports software installed on your computer, do one of the following:
  - If you have Crystal Reports 2008 SP01 installed, follow the procedures for installing the Crystal Reports version for SAP Business One, as described in the section: Installing Crystal Reports for SAP Business One.
  - If you have Crystal Reports 2008 SP00 installed:
    - Uninstall Crystal Reports 2008 SP00.
    - Follow the installation procedures for installing the Crystal Reports version for SAP Business One, as described in the section: Installing Crystal Reports for SAP Business One.
  - If you have a version of the Crystal Reports software installed that is earlier than Crystal Reports 2008, you do not need to uninstall it before proceeding to install the Crystal Reports version for SAP Business One.
  - If you have the Crystal Reports integration add-on installed with any of the SAP Business One 2007 or 2005 releases, you must first uninstall the add-on before proceeding to the installation of Crystal Reports version for SAP Business One.

- You have Microsoft SQL Server 2005, 2008, or 2008 R2 installed on your computer.

  **Note**
  
  If you do not have Microsoft SQL Server 2005, 2008 or 2008 R2 already installed on your computer, you can install either one during the installation process if you have the Microsoft SQL Server 2005, 2008 or 2008 R2 DVD.

- To properly use the SAP Business One Fixed Assets add-on on Microsoft SQL Server 2005, make sure that you have Microsoft SQL Server 2005 SP3 installed.

- In the SAP Business One server installation and upgrade procedures, you have the option of installing remote support platform for SAP Business One. For more information, see the Administrator’s Guide to Remote Support Platform for SAP Business One document under ...\Documentation\ on the SAP Business One product DVD or on the dedicated landing page in SAP Channel Partner Portal at http://channel.sap.com/sbo/rsp.

2.1. Constraints

You can run the SAP Business One product version for 31 days without a license. To continue working with the application after 31 days, you must install a valid license key assigned by SAP.

  **Note**
  
  If you are a partner, for more information about installing the license key, see License Guide SAP Business One 8.81 in SAP Channel Partner Portal at http://channel.sap.com/sbo/documentation.

The demo databases provided are not for productive use. The application supports 40 localizations in its demo databases.

### 2.2. User Privileges

The following table summarizes the requirements and recommendations for the group setup of the displayed operating system:

<table>
<thead>
<tr>
<th>Operating System Process</th>
<th>Windows XP, Windows Vista, Windows 7</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Recommended</strong></td>
</tr>
<tr>
<td>Client installation</td>
<td>Administrator</td>
</tr>
<tr>
<td>Client upgrade</td>
<td>Administrator</td>
</tr>
<tr>
<td>Runtime</td>
<td>Users</td>
</tr>
</tbody>
</table>

SAP Business One supports the Microsoft Windows XP, Windows Vista, and Windows 7 operating systems in a server configuration environment for standalone systems and clients.

**Note**

For more information about possible installer issues related to the user account control (UAC) in Microsoft Windows operating systems, see SAP Note [1492196](#).

### 2.3. Installation Checklist

To perform a correct and complete installation, do the following:

1. Install the Crystal Reports version for SAP Business One.
3. Install the SAP Business One server tools.
4. Install the SAP Business One server components.
5. Install the SAP Business One client application on workstations.
6. Install optional components (add-ons, SDK).
7. Install integration component for SAP Business One.

The precise sequence of these steps depends on your installation scenario. For more information, see the relevant sections under [Performing SAP Business One Installations on Client Computers](#).
3. Installing SAP Business One

Based on common business scenarios, the three widely used installation scenarios for SAP Business One are as follows:

- **Server-client mode:** SAP Business One server and server tools are installed on one computer; one or more clients are installed on other computers.
- **Standalone mode:** For a central SAP Business One installation, server components and clients are installed on one computer.
- **Remote mode:** For a remote server-client SAP Business One installation, SAP Business One is installed on a terminal server or in a Citrix environment.

**Note**

For more installation information about the Crystal Reports version for the SAP Business One, see [Installing Crystal Reports for SAP Business One](#).

3.1. Scenarios

You can install SAP Business One using one of the following scenarios:

- **Server-client mode:**
  
  Server-client mode is considered best practice for an SAP Business One installation. In this mode, you install the following on the server computer:
  
  a. SAP Business One server tools
  b. SAP Business One server
  c. Microsoft Outlook integration add-on
  d. Integration component for SAP Business One

  You install the following on client computers:
  
  a. SAP Business One client
  b. Optional client components, which include:
     
     - SBO Mailer and fax service
     - Software Development Kit (SDK)
     - Data Transfer Workbench
     - Microsoft Outlook integration add-on standalone version

- **Standalone mode:**

  You install all the server and client components on one computer. They are as follows:

  o SAP Business One server tools
  o SAP Business One server
  o Microsoft Outlook integration server installer add-on
  o Integration component for SAP Business One
  o SAP Business One client
  o Optional client components
• Remote mode:
  This mode enables logging on to SAP Business One from a remote computer.
  
a. You install the following on a remote server computer:
   i. SAP Business One server tools
   ii. SAP Business One server components
   iii. Microsoft Outlook integration add-on
   iv. Integration component for SAP Business One
   v. SAP Business One client
   vi. Optional client components
   vii. Microsoft Windows server terminal services
  
b. You install Microsoft terminal services client on terminal client computers.

3.2. Installing SAP Business One in Server-Client Mode

In this scenario, you perform the server computer installations and the client computer installations separately, as shown in Figure 3 below:

![Figure 3: Server-Client Landscape](image)

3.2.1. Performing an SAP Business One Installation on Server Computers

You need to perform the following actions on the server computer:

1. Install SAP Business One server tools.
2. Install SAP Business One server components.
   Server components include the following:
   o SAP Business One server application
3. Register the add-ons.

The installation of the server components automatically registers all SAP add-ons on the server computer. There is no need for additional registering.

The SAP Business One server application automatically registers SAP add-ons to all companies on the server. Add-ons appear in the Available Add-_Ons list in the Add-On Administration window.

For more information, see Assigning SAP Business One Add-Ons.

**CAUTION**

The SAP Business One installation creates a new SQL user and password. Do not modify or delete this user ID or password. They are essential for the correct operation of the SAP Business One application.

4. Change the sa login password or create an alternative user.

For security reasons, we recommend that you either change the sa logon password right after installing SAP Business One, or as a safer option, create a user to serve as a substitute for the sa user. For more information, see Database Authentication.

**Prerequisites**

- The installation computer complies with all hardware and software requirements. For information on hardware and software requirements, refer to http://channel.sap.com/sbo/platforms.
- You have administrator rights on the computer on which you are performing the installation.

**Note**

For more information about possible installer issues related to the user account control (UAC) in Microsoft Windows operating systems, see SAP Note 1492196.

3.2.1.1. Installing Microsoft SQL Server 2005, Microsoft SQL Server 2008, or Microsoft SQL Server 2008

**Note**

The information given for Microsoft SQL Server 2008 is also valid for Microsoft SQL 2008 R2.
Procedure

1. Insert the SAP Business One product DVD in the DVD drive.

   The installation program appears automatically. If the DVD does not launch the installation program, navigate to the DVD root folder and double-click the Autorun.exe file. If you are using Windows Vista, Windows Server 2008, or Windows 7, right-click the Autorun.exe file and choose Run as administrator.

   The SAP Business One Installation window appears.

2. In the installation window, select the Server radio button, and choose the Next button.

   If you have already installed Microsoft SQL Server 2005 or Microsoft SQL Server 2008, proceed with Changing the sa Login Password and Creating an Alternative User.

3. If Microsoft SQL Server 2005 or Microsoft SQL Server 2008 cannot be detected, the Microsoft SQL Server 2005 or Microsoft SQL Server 2008 installation window appears. Do one of the following:

   - To install Microsoft SQL Server 2005 or Microsoft SQL Server 2008 on the computer, select the Install Microsoft SQL Server 2005 or 2008 on this machine checkbox on this computer and continue with step 4.

   **CAUTION**

   Make sure that the name of the computer on which you are installing Microsoft SQL Server does not contain any of the following special characters:

   - &
   - <
Make sure that you align your computer name with the name format of your license server. To check or correct your computer name, proceed as follows:

2. In the System Properties window, select the Computer Name tab.
3. In the Computer name field, check the computer name.
4. To correct the computer name, choose the Change button.
5. In the Computer Name/Domain Changes window, specify a new name for the computer and choose the OK button.

If you already have Microsoft SQL Server installed, to continue with the SAP Business One installation, select the checkbox: If you are sure that Microsoft SQL Server 2005 or 2008 has been installed, continue installing SAP Business One. Continue with step 3 of Installing the Server Tools.

4. In the Microsoft SQL Server Installation window, do the following:
   a. Insert the Microsoft SQL Server 2005 or Microsoft SQL Server 2008 DVD in the DVD drive.
   b. In the Installation Folder field, specify the folder in which you want to install the Microsoft SQL Server. To change the default installation directory, choose the Browse button.
c. To start the silent installation, choose the Install button.

5. In the message dialog box, choose the OK button.

6. In the Choose file window, locate the Microsoft SQL Server 2005 or 2008 installation file (setup.exe).
   Choose the Open button.

   The setup begins a silent installation of SQL Server components and applies the default values as shown in the table below.

   **CAUTION**

   If you do not have Microsoft .NET Framework 3.5 installed on your computer, it is installed as part of the installation process during the silent installation of Microsoft SQL 2008. This requires restarting your computer before you can proceed with the Microsoft SQL 2008 installation.

   After you restart your computer, you need to start the installation procedure from the beginning (step 1). In step 6, in the Choose file window, locate the Microsoft SQL Server 2008 installation file (setup.exe) and proceed with the installation procedure.

   **Note**

   Due to the following limitation in Windows Vista and Windows Server 2008, if you are working with either of these, the following applies:

   If you are installing Microsoft SQL Server 2005 or 2008, at the end of the silent installation, the Windows Desktop may disappear, because of the Run as Administrator permissions settings.
If the Windows Desktop disappears, log off from Windows after the Microsoft SQL Server installation, then log back on and start the SAP Business One installation process from step 1.

**Note**

If you did not install Microsoft SQL Server 2005 or Microsoft SQL Server 2008 through the SAP Business One installation, make sure that you enter the connection settings that match the setup of the SAP Business One application, as shown in the table below.

<table>
<thead>
<tr>
<th>Window Name</th>
<th>Fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>Registration Information</td>
<td>• Name – copied from the local system</td>
</tr>
<tr>
<td></td>
<td>• Company – copied from the local system</td>
</tr>
<tr>
<td></td>
<td>• CDKey – copied from the installation DVD</td>
</tr>
<tr>
<td>Components to Install</td>
<td>SQL Server Database Service</td>
</tr>
<tr>
<td></td>
<td>Workstation Components, Books Online, and development tools</td>
</tr>
<tr>
<td>Instance Name</td>
<td>MSSQLServer</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong></td>
</tr>
<tr>
<td></td>
<td>Make sure that in the TCP/IP protocol properties of your SQL Server instance, the TCP Port field is set to 1433</td>
</tr>
<tr>
<td>Service Account</td>
<td>• Use the built-in system account – Local System</td>
</tr>
<tr>
<td></td>
<td>• Start the services at the end of the setup – SQL Server</td>
</tr>
<tr>
<td>Authentication Mode</td>
<td>• Mixed Mode (Windows Authentication and SQL Server Authentication)</td>
</tr>
<tr>
<td></td>
<td>• Password: SAPB1Admin</td>
</tr>
<tr>
<td>Collation Settings</td>
<td>SQL collations – Dictionary order case-insensitive, for use with 1252 Character set, Accent - Sensitive (SQL_Latin1_General_CP1_CI_AS).</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong></td>
</tr>
<tr>
<td></td>
<td>If you manually install SQL Server, in the Collation Settings window, select Latin1 General from the dropdown list and select the Accent – sensitive checkbox.</td>
</tr>
<tr>
<td>Error and Usage Report Settings</td>
<td>None marked</td>
</tr>
</tbody>
</table>

7. When Microsoft SQL Server 2005 or Microsoft SQL Server 2008 is installed successfully, and you can see the following confirmation window, you can remove the Microsoft SQL Server 2005 or 2008 DVD.
To continue with the SAP Business One installation, choose the Next button.

**SAP BUSINESS ONE 8.81 INSTALLATION**

MICROSOFT SQL SERVER INSTALLATION

Microsoft SQL Server has been successfully installed on your computer.

For this installation, a default password has been assigned: **SAP81Admin**

For security reasons, change the password later on.

Insert the SAP Business One DVD and click the Next button.

### 3.2.1.2. Changing the sa Login Password and Creating an Alternative User

For security reasons, we recommend that you change the **sa** logon password right after installing SAP Business One, or create an alternative user to the **sa** user, which is the safest option. For more information, see **Database Authentication**.
3.2.1.3. Installing the Server Tools

1. Reinsert the SAP Business One product DVD in the DVD drive.

   The installation program appears automatically. If the DVD does not launch the installation program, navigate to the DVD root folder and double-click the Autorun.exe file. If you are using Windows Vista, Windows Server 2008, or Windows 7, right-click the Autorun.exe file and choose Run as administrator.

2. From the installation window, select the Server radio button, and choose the Next button.

3. In the Server Components window, do one of the following:
   - To automatically install all required server components in one batch, on the same computer, select the Full radio button.
   - To install server components individually, select the Custom radio button and select the option that you want to install.

   **Recommendation**
   We recommend that you select the Custom option, because this option lets you view all available server components. You can then select the components that you want to install on different computers.

   Choose the Install button. The InstallShield wizard begins running.

   **CAUTION**
   It may take some time for the InstallShield wizard to appear. While you are waiting for the wizard to load, do not activate any other window.
4. In the Welcome window, choose the Next button.
5. In the Customer Information window, specify your user ID and company name and choose the Next button.

![SAP Business One Server Tools - InstallShield Wizard](image)

6. In the Setup Type window, do one of the following:

- To view all the options and choose the ones you want to install, select the Custom radio button.
- To perform a typical installation, select the Typical radio button. Choose the Next button.
For a typical installation, proceed to Step 9.

**SAP Business One Server Tools - InstallShield Wizard**

**Setup Type**

Select a setup type, then choose the Next button.

- **Typical**
  - Typical installation includes the most common components. Recommended for most users.

- **Compact**
  - Compact installation includes the minimum required components and SAP Business One Mailer Service.

- **Custom**
  - Custom installation lets you choose the options you want to install. Recommended for advanced users.

7. In the Select Destination Folder window, do one of the following:

   - To accept the default installation location for SAP Business One server components, choose the Next button.
   - To select a different location, choose the Browse button, select a directory, and choose the Next button.

**CAUTION**

To install the server components and all additional components, use the standard directory (\SAP\SAP Business One Server). If you change the path, do not change the directory names. This rule also applies to the installation of the server components and the client components.
8. In the *Select Features* window, select the components you want to install and deselect the features you do not want to install.

**Note**

To use any component of server tools, you have to operate through SAP Business One Service Manager. Hence, the service manager checkbox is automatically selected and cannot be reset.
Choose the Next button.

9. In the Define Site User Password window, specify the site user password, and then choose the Next button.

The site user ID serves as site-level authentication for performing the following activities:

- Configuring database credentials
- Creating companies
- Configuring services
- Registering add-ons
- Updating read-only user passwords

A site user password is required for authentication against the license server during the following situations:

- Configuring services via SAP Business One Service Manager
- Installing SAP Business One servers
- Creating new companies on SAP Business One clients

**Note**

To configure any service in the service manager after installation, you have to specify the site user password only on the first logon.

**Recommendation**

For security reasons, you should set a strong site user password, at least as strong as that defined in your company's password policy, and change it frequently. For more information, see *Managing Security in SAP Business One*. 
10. In the Complete window, choose the Finish button.

3.2.1.4. Installing the SAP Business One Server

Prerequisite

- You have your computer’s name or IP address available.
  - To check your computer’s full name, do the following:
    1. In Windows, on the Desktop, right-click the My Computer icon and select Properties.
    2. The name of your computer appears in the System Properties window, on the Computer Name tab, next to the Full computer name field.
    3. Keep a record of the displayed computer name.
  - To check your computer’s IP address, do the following:
    1. In Windows, choose Start → Run.
    2. In the Open field of the Run window, enter cmd and press Enter.
    3. In the cmd.exe window, enter ipconfig and press Enter.
    4. Keep a record of the displayed IP address.

- If the SAP Business One license server is installed on a different computer, make sure that the license server is running when you are installing the SAP Business One server. For information about starting up your license server, see Configuring the License Manager.
Procedure

1. In the Server Components window, you can see that the installed Server Tools option is marked as installed now. To continue with the SAP Business One server installation, select the SAP Business One Server checkbox.

   Choose the Install button.

2. In the Welcome window, to continue, choose the Next button.
3. In the **Customer Information** window, specify your user ID and company name, and then choose the **Next** button.

4. If your license server is installed on a different computer, the **License Authentication** window appears; otherwise, proceed to step 5.

   In the **License Authentication** window, specify the license server information you defined in the server tools installation.

   Choose the **Next** button.
If you have problems specifying the license server address, use the IP address of the license server.

**CAUTION**

Use standard ports. Changing the ports can affect the installation of the components that follows this installation. This rule applies to the installation of all the server and client components.

![SAP Business One Server - InstallShield Wizard](image)

License Authentication

Please fill license authentication information:

- **Site User ID**: BTSiteUser
- **Password**: [***]
- **License Server**: [***]  **Port**: 30000

[< Back][Next >][Cancel]
5. In the Setup Type window, select a setup type from those listed below, and then choose the Next button.

- **Typical**: lets you install all components. If you select the Typical radio button, proceed to step 7.
- **Custom**: lets you view all the installation options so you can choose the options you want to install.

![SAP Business One Server - InstallShield Wizard](image)

Select a setup type, then choose the Next button.

- **Typical**: Typical installation includes the most common components. Recommended for most users.
- **Custom**: Custom installation lets you choose the options you want to install. Recommended for advanced users.
6. In the *Select Destination Folder* window, do one of the following:
   - To accept the default installation location for SAP Business One server components, choose the *Next* button.
   - To select a different location, choose the *Browse* button. In the *Choose Folder* window, specify a directory, and then choose the *Next* button.
7. In the Select Database Server Type window, in the Server Type dropdown list, select the database type installed on the server computer and choose the Next button.

8. In the Database Server Logon window, specify the following database server connection settings.
   - Server Name – Specify the server computer name.
     
     **Note**
     
     If specifying a computer name does not work, try the IP address of the server computer. Be sure the format is consistent with what you have defined for the license server.
     
     **CAUTION**
     
     Make sure that in the Server Name field, the name of the computer on which you installed Microsoft SQL Server does not contain special characters, such as: & , < , > , " , or '.
     
     To check or correct your computer name, proceed as follows:
     
     i. Choose Start → Control Panel → System.
     
     ii. In the System Properties window, select the Computer Name tab.
     
     iii. In the Computer name field, check the computer name.
     
     iv. To correct the computer name, choose the Change button.
     
     v. In the Computer Name/Domain Changes window, specify a new name for the computer and choose the OK button.
   - Database User ID – specify the user ID to access the Microsoft SQL server.
   - Database Password – specify the password to access the Microsoft SQL server.
     
     Choose the Next button.
If you used the SAP Business One silent installation for Microsoft SQL Server, then the default user ID and password values are: sa and SAPB1Admin (case sensitive).

**Recommendation**

After installing SAP Business One, you should change the sa password or create a new database administrator. For more information, see Changing the sa Login Password and Creating an Alternative User.

Check your password and user ID, and make sure that you have installed an SQL Server database server.

If you selected the Typical installation option in step 5, proceed to step 10.

9. In the Select Features window, select the features you want to install from among the following:

- **System Databases** installs the SAP Business One common database (SBO-COMMON). This database is visible only at the Microsoft SQL level, not in the list of companies at the application level. It is updated every time you install a new patch or perform an upgrade to SAP Business One. The default values in the common database are available for every new database that is created.

- **Demo Databases** installs demonstration databases in the selected localizations.

- **Help** installs the help files in the selected languages.

- **Server Components** installs shared network objects.

- **SAP Add-ons** registers the SAP add-ons on the server computer.

**Note**

If you want to install SAP add-ons, you must select the SAP Add-ons checkbox in the Select Features window. For information, see Assigning SAP Business One Add-Ons.
o **Remote support platform** installs remote support platform for SAP Business One on the server computer.

- To install the application, select the checkbox *remote support platform*. The installation is performed by the installation wizard of remote support platform for SAP Business One later on. For more information, see the document *Administrator’s Guide to Remote Support Platform for SAP Business One* in the product DVD or on the dedicated landing page in SAP Channel Partner Portal at [http://channel.sap.com/sbo/rsp](http://channel.sap.com/sbo/rsp).

  **Note**

  If the installation of remote support platform for SAP Business One fails, this does not affect the successful installation SAP Business One.

  The installation of remote support platform for SAP Business One does not impact SAP Business One business processes. There is no technical dependency between SAP Business One and remote support platform for SAP Business One.

- To install SAP Business One without installing remote support platform for SAP Business One, make sure that you deselect the checkbox *remote support platform for SAP Business One*, and then choose the *Next* button.

  **Note**

  The features you select here depend on your system environment. Therefore, some features may not be available to you.
10. In the *Review Settings* window, do one of the following:
   - To confirm all the settings, choose the *Next* button.
   - To change any settings, choose the *Back* button to return to previous windows.

11. In the *Setup Status* window, the setup wizard begins copying files, which may take several minutes, depending on the number of demo databases you selected for installation and on your computer performance.

12. In the *Setup Complete* window, choose the *Finish* button.
If you selected the *Typical* installation option in step 5 of the server installation procedure, proceed to step 2 in *Installing the Microsoft Outlook Integration Server*.

### 3.2.1.5. Installing the Microsoft Outlook Integration Server

This setup installs Microsoft Office templates required for the Microsoft Outlook integration server add-on.

**Procedure**

1. In the *Server Components* window, you can see that the *Server Tools (Installed)* and the *SAP Business One Server (Installed)* checkboxes are inactive now. To continue with the Microsoft Outlook integration add-on server installation, select the *Microsoft Outlook Integration Server Add-On* checkbox.

2. Choose the *Install* button.
3. In the Welcome window, choose the Next button.

4. In the Select Destination Folder window, do one of the following:
   - To confirm the default installation location, choose the Next button.
To change the default location, choose the *Browse* button to locate a directory, and then choose the *Next* button.

5. In the *Review Settings* window, review the settings you have made, and then proceed as follows:
   - To continue, choose the *Next* button.
   - To change the settings, choose the *Back* button to return to the previous steps.

6. The *Setup Status* window displays the installation program performing the required actions.
7. In the Complete window, choose the Finish button to exit the wizard. After you have finished the server installation, proceed to Performing SAP Business One Installations on Client Computers.

8. In the Server Components installation summary window, choose the Finish button.
3.2.2. Performing SAP Business One Installations on Client Computers

You can install the client application on every workstation that needs to run SAP Business One. Depending on the required configuration, you can decide which optional components to install on each workstation.

The client components include:

- SAP Business One client application and DI API.
- Mail and fax services - installs messaging services that enable sending fax and mail messages from SAP Business One. For more information, see Configuring the Fax Service.
- Software Development Kit - installs documentation and samples for the SAP Business One SDK.
- Data Transfer Workbench - installs a tool for migrating legacy data into SAP Business One.
- Microsoft Outlook integration add-on standalone version - installs a version of Outlook integration that lets you use this add-on without the SAP Business One client application. For more information, see Installing SAP Business One in Standalone Mode.

Prerequisites

- The installation computer complies with all hardware and software requirements. For information on hardware and software requirements, refer to http://channel.sap.com/sbo/platforms.
- You have installed Microsoft .NET Framework 3.0. During the installation of the SAP Business One Client, the system checks whether Microsoft .NET Framework 3.0 is installed. If it is not installed yet, you can install it during client installation. This step is mandatory.
- You have installed Microsoft Visual C++ 2005 SP1 Redistributable Package. If it is not installed yet, you can install it during client installation. This step is mandatory.
- You have installed Microsoft Excel.
- You have installed the Crystal Reports version for SAP Business One so as to be able to use the SAP Business One data source on the client computer. This data source provides SAP Business One tables in a hierarchical tree organized according to the SAP Business One modules. For information about installing the Crystal Reports version for SAP Business One, see Installing Crystal Reports for SAP Business One.

3.2.2.1. Installing the SAP Business One Client

Procedure

1. Insert the DVD in the DVD drive of the workstation or computer on which you want to install the client and wait for the installation program to appear. Alternatively, you can install the client application from .../SAP/SAP Business One Server/B1_SHR/Clients/setup.exe.

2. In the installation window, select the Client radio button.

   CAUTION

   To continue with the client installation, make sure that the license server is running. For information on how to start up your license server, see Configuring the License Manager.
3. In the Client Components window, select the SAP Business One Client checkbox and the optional components you want to install.
Choose the *Install* button.

The installation procedure checks whether you have installed Microsoft .NET Framework 3.0 and Microsoft Visual C++ 2005 SP1 Redistributable Package. If these are not installed yet, you can install them by choosing *Install* on the relevant screens.

4. For more information about installing the Crystal Reports software on the client computer, see [Installing Crystal Reports for SAP Business One](#).

The SAP Business One data sources and *Add-ins* menu for Crystal Reports are installed after Crystal Reports Viewer or the Crystal Reports version for SAP Business One is installed.
5. In the Welcome window, choose the Next button.

6. In the Customer Information window, specify the user ID and company name.
7. In the Select Destination Folder window, to accept the default location, choose the Next button. To select a different location, choose the Browse button.

8. In the Select Program Folder window, make sure SAP Business One is displayed in both fields, and then choose the Next button.
9. In the License Server Details window, specify the license server name.
Choose the Next button.

10. In the Setup Status window, the installation wizard performs the required system actions.
11. In the Complete window, choose the Finish button.
3.2.2.2. Installing SAP Business One SDK (Software Development Kit)

**Note**

It may take a few minutes until the SDK setup wizard appears.

**Procedure**

1. In the Welcome window, to continue, choose the Next button.
2. In the *Customer Information* window, specify the user ID and company name. Choose the *Next* button.

![SAP Business One Software Development Kit - InstallSh...](image)

Enter your details.

User ID

Company Name

3. In the *Setup Type* window, do the following:

   - To choose a custom installation in which you can select each option you want to install, select the *Custom* radio button.
   - To perform a regular installation, select the *Typical* radio button.
Choose the Next button. For a typical installation, to continue, proceed to step 6.

4. In the Select Destination Folder window, specify the folder in which you want to install SDK, and then choose the Next button.

   ![Select Destination Folder](image)
5. In the *Select Components* window, select each component you want to install and deselect those you do not want to install. Choose the *Next* button.

6. In the *Setup Status* window, wait for the system to perform the required actions.
7. In the *Complete* window, choose the *Finish* button.
3.2.2.3. Installing SAP Business One Data Transfer Workbench

**Note**
It may take a few minutes until the Data Transfer Workbench setup wizard appears.

**Procedure**
1. In the *Welcome* window, choose the *Next* button.
2. In the **Select Destination Folder** window, specify the folder in which you want to install Data Transfer Workbench.

![Select Destination Folder](image)

3. In the **Select Program Folder** window, specify the program folder you want to install for Data Transfer Workbench.

![Select Program Folder](image)
4. In the Review Settings window, review the settings you have made:
   - To continue, choose the Next button.
   - To change the settings, choose the Back button to return to the previous steps.

5. In the Complete window, choose the Finish button.
3.2.2.4. Installing the Microsoft Outlook Integration Add-On

Note
It may take a few minutes for the setup wizard to launch the installation wizard for the Microsoft Outlook integration add-on.

Procedure
1. In the Welcome window, choose the Next button.
2. In the Select Destination Folder window, specify the folder in which you want to install the Microsoft Outlook integration add-on. Choose the Next button.

3. In the Review Settings window, review the settings you have made, then do one of the following:
   - To continue, choose the Next button.
   - To change the settings, choose the Back button to return to the previous pages.

4. In the Complete window, choose the Finish button.
5. After you have finished installing all the client components, a summary window appears and you can see a list of the components installed on your computer.

**SAP Business One 8.81 Installation**

Client Components

The following server components have been successfully installed:

- SAP Business One Client
- Mail and Fax Service
- Software Development Kit (SDK)
- Data Transfer Workbench
- Microsoft Outlook Integration Standalone Add-On
3.2.3. Installing Integration Component for SAP Business One

Integration component for SAP Business One is made up of the following components:

- SAP Business One integration Server
- SAP Business One integration EventSender
- SAP Business One integration DI-Proxy
- Packages for Mobile Solution/ DATEV HR (Germany only) and B1 Cockpit Support

Installing integration component for SAP Business One is optional. However, to use and work with dashboards and to enable users to work with mobile devices using SAP Business One, you must install SAP Business One 8.81 and integration component for SAP Business One. For more information about dashboards and mobile scenarios, see Working With Dashboards in Integration Component and Setting Up the Mobile Scenario in Integration Component in the …\Documentation\B1 Integration Component folder of the product DVD.

For more information about DATEV HR, see Leitfaden zur Personalabrechnung mit DATEV HR (German only) in the …\Documentation\B1 Integration Component folder of the product DVD.

Prerequisites

Before you start the installation process, ensure that the following are in place:

- SAP Business One 8.81– including SAP Business One DI API

**Recommendation**

The latest version of the DI API should be installed, and the database set up to allow TCP/IP connections. To do this, follow the procedures described in Installing the Latest SAP Business One DI API and Setting Up the TCP/IP Protocol for the Database Server below.

For more information, see Installation Guide for SAP Business One DI API.

- Adobe Flash Player 10.0 is installed on the client workstation to support the display of dashboards

Installing the Latest SAP Business One DI API

If the SAP Business One client is not installed, use the following procedure to install the latest SAP Business One DI API:

1. In the *Setup Type* window of the *SAP Business One DI API InstallShield Wizard*, select the *Custom* type.

2. To install the latest DI API version, in the *Select Components* window of the *SAP Business One DI API InstallShield Wizard*, deselect the *DI API previous versions* checkbox.

Setting Up the TCP/IP Protocol for the Database Server

If you are using MS SQL Server 2005 or 2008, you must ensure that the database TCP/IP protocol is enabled.

**CAUTION**

In SQL Server 2005 / 2008, the TCP/IP protocol is **disabled** by default.
NOTE

The procedure is the same for both Microsoft SQL Server 2005 and Microsoft SQL Server 2008. In the SQL Server Configuration Manager, the release name for the SQL Server Services is displayed for 2005 (SQL Server 2005 Services) but not for 2008 (SQL Server Services).

1. Enable the TCP/IP protocol in SQL Server 2005 as follows:
   a. Choose Start → All Programs → Microsoft SQL Server 2005 → Configuration Tools → SQL Server Configuration Manager.
   b. In the SQL Server Configuration Manager window, expand SQL Server 2005 Network Configuration and choose Protocols for MSSQLSERVER.
   c. Right-click TCP/IP, and choose Enable.
   d. Go to SQL Server 2005 Services and restart the SQL Server (MSSQLSERVER).

NOTE

MSSQLSERVER is the default instance of MSSQL. If named instances have been installed, these have different names.

2. Set the IP port in SQL Server 2005 as follows:
   a. Choose Start → All Programs → Microsoft SQL Server 2005 → Configuration Tools → SQL Server Configuration Manager.
   b. In the SQL Server Configuration Manager window, expand SQL Server 2005 Network Configuration and choose Protocols for <instance name>.
   c. Open TCP/IP Properties by double-clicking TCP/IP, or by right-clicking TCP/IP and choosing Properties.
   d. On the IP Addresses tab, in the section IPALL, leave the TCP Dynamic Ports field blank and enter, for example 1433, in the TCP Port field.

NOTE

If you are using SQL Server named instances, make sure each instance uses a different TCP/IP port and, during the installation of integration component, enter the server name as <server name> rather than the <server name>\instance name.
Procedure

1. Insert the SAP Business One product DVD in the DVD drive.
   The installation program appears automatically. If the DVD does not launch the installation program, navigate to the DVD root folder and double-click the Autorun.exe file.
   The SAP Business One Installation window appears.

2. In the installation window, select Integration Component radio button, and choose the Next button.
   The InstallShield Wizard window opens.

3. In the InstallShield Wizard welcome window, choose Next.

4. In the Customer Information window, enter your user name and company name in their respective fields, select one of the following options, and choose Next.
   - Anyone who uses this computer (all users)
   - Only for me (the user's personal user number is displayed in brackets)

5. In the Choose Destination Location window, choose Browse, select the location at which the copied files should be stored, and choose Next.
   In the Action Review window, a summary is shown of the three components that will be installed.

6. Set the B1iadmin user password, and choose Next.

7. To start the installation and upgrade process, choose Next.
   To cancel the process and discard your settings, choose Cancel.

8. Select the database type for SAP Business One integration server by choosing an option from the drop-down menu, and choose Next.

9. In the Database Server Login window, enter the following information and choose Next:
   - Server
   - Port
   - User Name
   - Password

   **NOTE**
   The database name is set by default to B1if.
10. In the Action Review window, you can review or change any of the settings you have made before you finalize them and initiate the file copying process. A summary of your current settings is also shown.

    To review or change your settings, choose Back.
    To finalize your settings and begin the file copying process, choose Next.

11. In the Company Database Information window, enter the following information for the SAP Business One company database that you want to use with integration component for SAP Business One, and choose Next.

    - SAP Business One Server
    - License Server: Port
    - DB User Name
    - DB Password
    - DI API JCo LIB Path
    - User Name
    - Password

**NOTE**

The User Name is preset to B1i, which is the technical user that is reserved for use with SAP Business One integration solutions.

A user with this code is created for every new company database, but you must ensure that the password of this user is properly initialized. To do this, you must set the password in SAP Business One, if you have not done so already.
NOTE
Some fields, such as the License Server field, are already populated with the relevant information (for example, <server name> : <Port> for License Server). Check whether this information is correct.

RECOMMENDATION
Make sure you choose the correct path to the Java Connector (JCO) libraries for the SAP Business One Interface API (DI API).

12. After you have set the company database information, select whether to activate payroll support (DATEV/HR package, Germany only) and set the destination folder for incoming files and outgoing files.

You can choose not to activate payroll support at this stage. To do so, deselect the Activate payroll support (Germany only) option. For more information about activating payroll support later, see Leitfaden zur Personalabrechnung mit DATEV HR (German only) in the ...\Documentation\B1 Integration Component folder of the product DVD.
13. Select whether to activate support for SAP Business One Mobile solution.

You can choose not to activate SAP Business One Mobile solution support at this stage. To do so, deselect the **Activate support for SAP Business One Mobile solution** option. For more information, see **Setting Up the Mobile Scenario in Integration Component** in the ...\Documentation\B1 Integration Component folder of the product DVD.

14. When the installation process is complete, choose **Finish**.

**Result**

After installation, the application automatically starts the integration service for SAP Business One.
For information about technical monitoring and maintenance as well as security, see the 
Administrator's Guide for Integration Component.

NOTE

If any issues or errors arose during installation, the setup can be started again, however 
this causes the setup to enter Repair Mode.

Repair mode repairs the components, but leaves the packages, system settings and 
B1admin user password unchanged.
3.3. Installing SAP Business One in Standalone Mode

In this scenario, you can install the SAP Business One server and client on one computer, as shown in Figure 4 below:

![Figure 4: Standalone Landscape](image)

3.3.1. Installing SAP Business One on One Computer

To install the SAP Business One server and client components on one computer, proceed as follows:

1. Perform the installation of the server tool and server components as described in Installing SAP Business One in Server-Client Mode.

2. Perform the installation of the client application and components as described in Installing SAP Business One in Server-Client Mode.

3. Perform the installation of integration component for SAP Business One as described in Installing Integration Component for SAP Business One.
3.4. Installing SAP Business One in Remote Mode

In this scenario, you can perform the SAP Business One server and client installation on a remote computer, as shown in Figure 5 below:

![Figure 5: Microsoft Windows Server Terminal Landscape](image)

3.4.1. Installing SAP Business One on a Remote Computer

The following example describes the setup of Microsoft Windows Server 2003 Terminal Service for the hosted environment setup.

**Prerequisite**
- The installation complies with all hardware and software requirements. For information on hardware and software requirements, refer to [http://channel.sap.com/sbo/platforms](http://channel.sap.com/sbo/platforms).

**Procedure**

To perform the installation of SAP Business One on a remote computer, proceed as follows:

1. **Install Microsoft Windows Server Terminal Services.**
   a. On the server computer, open the *Control Panel* and double-click *Add/Remove Programs*.
   b. In the *Add/Remove Programs* window, choose *Add/Remove Windows Components*.
      The *Windows Components Wizard* opens. You may have to close the *Add/Remove Programs* window.
   c. In the list of optional components, select *Terminal Services* and *Terminal Services Licensing*.
   d. To install terminal service components, choose the *Next* button.
      The wizard verifies whether you want to install the terminal services in Remote Administration mode or in Application Server mode.
**Recommendation**

Select *Application Server* mode as it supports an unlimited number of connections. In addition, you should keep the default installation values.

e. In *Application Server* mode, install the software from Windows *Control Panel* by choosing *Add/Remove Programs* → *Add New Programs*.

f. The setup wizard prompts you to insert Microsoft Windows Server 2003 installation media.

   After copying files, the wizard informs you that the terminal services have been installed and that you need to reboot the server computer.

2. Install the following in sequence, as described in the section *Installing SAP Business One in Server-Client Mode*.

   a. SAP Business One server tools
   b. SAP Business One server components
   c. SAP Business One client
   d. Integration component for SAP Business One

3. Change the *sa* logon password and create an alternative user.

   For security reasons, you should change the *sa* logon password right after installing SAP Business One, or create a user to substitute for the *sa* user, which is the safest option. For more information, see *Database Authentication*.

### 3.4.2. Performing a Client Installation

You can create the client setup disks from the *Terminal Server-Client* menu on the terminal server.

**Procedure**

To install the terminal services client, proceed as follows:

1. Run the setup program on your workstation.

2. From the Microsoft Windows task bar, choose *Start → Programs → Terminal Server Client* and select *Client Connection Wizard*.

3. When the wizard appears, specify the name of the terminal server and a description for the connection.

   **Note**

   If you experience problems entering an actual server name in the *Server Name* field, specify the server IP address.

   **Recommendation**

   If you manage multiple servers on one workstation, specifying the server name in the *Description* field makes it easy to identify each connection.
3.5. Installing Crystal Reports for SAP Business One

Prerequisites
If you already have the Crystal Reports software installed on your computer, do one of the following:

- If you have Crystal Reports 2008 SP01 installed, you can follow the procedures for installing the Crystal Reports version for SAP Business One as described in the section: Installing Crystal Reports for SAP Business One.

- If you have Crystal Reports 2008 SP00 installed:
  a. Uninstall Crystal Reports 2008 SP00.
  b. Follow the installation procedures for installing the Crystal Reports version for SAP Business One as described in the section: Installing Crystal Reports for SAP Business One.

- If you have a release of the Crystal Reports software installed that is earlier than Crystal Reports 2008, you do not need to uninstall it before proceeding to install the Crystal Reports version for SAP Business One.

- If you have the Crystal Reports integration add-on installed with any of the SAP Business One 2007 or 2005 releases, you must first uninstall the add-on before proceeding to the installation of Crystal Reports version for SAP Business One.

3.5.1. Installing Crystal Reports 2008 SP01

Note
If you have Crystal Reports 2008 SP00 installed on the computer where you want to install the Crystal Reports version for SAP Business One, you will be prompted to uninstall it during the installation procedure.

Recommendation
We recommend that you install SAP Business One 8.81 after installing the Crystal Reports version for SAP Business One as shown in the steps above and following procedures. If you have already installed SAP Business One, you may need to run a script that will enable the SAP Business One data source, which shows all the SAP Business One tables organized according to the modules in the SAP Business One Main Menu. For more information, see Running the Crystal Reports Integration Package Script.

Note
For more information about the Crystal Reports version for SAP Business One, see How to Work with Crystal Reports in SAP Business One in the documentation area of SAP Business One Customer Portal at http://service.sap.com/smb/sbocustomer/documentation.

Procedure
1. On the Crystal Reports DVD, in the CR_2008_SP01_for_B1 folder, double-click the setup.exe file.

2. In the Crystal Reports 2008 Setup window, do the following:
   a. In the dropdown list, choose a setup language.
   b. Select the Create log file during installation checkbox if you want to create a log file of the installation process.
3. Choose the OK button.

The Welcome window appears, indicating that the installation wizard has started.

4. In the Welcome window, choose the Next button.

The License Agreement window appears.
5. Read the license agreement, select the *I accept the License Agreement* radio button, then choose the *Next* button.

The *Choose Language Packs* window appears.

6. Select the checkboxes of any languages you want to install.

7. Choose the *Next* button.
The Select Installation Type window appears.

8. Select the type of installation that you want to perform:
   - **Typical**
     Installs the most common application features.
   - **Custom**
     Lets you:
     - Choose the features that you want installed
     - Specify where they will be installed
     - Check the disk space required by each feature

9. To specify a different location from the default location shown in the Destination Folder directory path, choose the Browse button.

   **Note**
   The Browse button is inactive if you have done one of the following, because in these cases a destination folder already exists:
   - You have already installed SAP Business One; that is, before installing the Crystal Reports software.
   - You have already installed Crystal Reports Viewer. For example, this may be installed automatically when you install the SAP Business One 8.81 client.

10. Choose the Next button.
    If you have selected the **Typical** option in step 8, go to step 13.
    If you have selected the **Custom** option in step 8, the Select Features window appears.
The icons in the feature tree indicate whether the feature and its subfeatures will be installed, as follows:

- A white icon means that the feature and all its subfeatures will be installed.
- A shaded icon means that the feature and some of its subfeatures will be installed.
- A yellow 1 means that the feature will be installed when required (installed on demand).
- A red X means that the feature or subfeature is either unavailable or will not be installed.

The Crystal Reports software uses an "install on-demand" technology for some of its features. As a result, the first time a particular feature is used after being installed, there may be an extra wait for the "install on-demand" to complete. This behavior will affect new installations only once and will not occur when features are restarted.

To select the configuration and location of a feature or subfeature, click its icon.
11. Choose the Next button.

The Web Update Service Option window appears.

12. To disable the web update service, select the Disable Web Update Service checkbox.

13. Choose the Next button.

The Start Installation window appears.
14. Choose the Next button. 
   
The Crystal Reports 2008 window appears.

15. When the installation is complete, the Success window appears.

16. To exit the installation wizard, choose the Finish button.
3.5.2. Running the Crystal Reports Integration Package Script

If the SAP Business One data source does not appear when you run the Crystal Reports software, follow the procedure below.

**Note**


**Procedure**

1. On your computer, locate the **Crystal** folder according to the following directory path:
   
   ```
   C:\Program Files\SAP\SAP Business One\Crystal.
   ```
   
   - Double-click the file: **SAP Business One Crystal Report Integration Package.exe**.
   
   **Note**

   The folder path shown above may be different on your computer, depending on where you have installed SAP Business One and the Crystal Reports software. You can use the Microsoft Windows search facility on your computer to locate the folder and file.

2. In the **SAP Business One Crystal Report Integration Package - InstallShield Wizard** window, choose the **Next** button.

   ![InstallShield Wizard](image)

   *Welcome to the InstallShield Wizard for SAP Business One Crystal Report Integration Package*

   The InstallShield Wizard will install SAP Business One Crystal Report Integration Package on your computer. To continue, click Next.

3. In the *Setup Status* screen, a progress bar indicates the stages of the installation process. You do not need to provide any input in this screen.
4. The integration package has been installed successfully. To exit the wizard, choose the Finish button.
3.5.3. Updates and Patches for Crystal Reports for SAP Business One

**CAUTION**

Since you are using SAP Business One 8.81 together with an Original Equipment Manufacturer (OEM) version of Crystal Reports, do not apply standard Crystal Reports file or product updates (incl. Hot Fixes and Service Packs) as they are not designed to work with OEM versions of Crystal Reports.

File or product updates for the

- integrated Runtime version will be distributed together with SAP Business One 8.81
- Report Designer will be provided separately via a dedicated folder location in the software distribution center on SAP Service Marketplace

**Note**

Make sure, in case you are using both the integrated Runtime version and the Report Designer, that they are either on the same patch or Service Pack level or that the Report Designer is on a lower patch or Service Pack level than the Runtime version. If not, inconsistencies may occur.

To find out if you are using an OEM version of Crystal Reports

Start the Report Designer. There are two indicators in the Designer for determining an OEM version of Crystal Reports:

- If the title bar of the Designer indicates Crystal Reports for a certain product (such as Crystal Reports for SAP Business One), then you are using an OEM version.
- In the Help menu, choose the About entry (for example, About Crystal Reports). If the technical support phone number in the About box is not listed as (604) 669 8379, then you are using an OEM version.

If either of these indicators exists in your product, then you are using an OEM version of Crystal Reports.

3.6. Uninstalling SAP Business One

When you uninstall SAP Business One, you remove the application and all its components.

**Note**

You must uninstall all SAP Business One add-ons before uninstalling the SAP Business One server and client components.

**Procedure**

1. To uninstall SAP Business One add-ons, choose **Administration → Add-Ons → Add-On Administration** and proceed as follows:
   a. On the Company Preferences tab, under Company Assigned Add-Ons, select the add-ons you want to remove.
   b. Choose the arrow button between the two panels. This removes the add-ons from the list.
   c. In the Available Add-Ons list, select the add-ons you want to remove.
   d. Choose the Remove Add-On button, and then choose the Update button.

   SAP Business One automatically removes the add-ons that you have uninstalled the next time you start the SAP Business One application from any workstation that is connected to the server.
Note

You can move XL Reporter to the Available Add-Ons panel but you cannot remove XL Reporter in the Add-On Administration window. The Remove Add-On button is disabled for XL Reporter.

In the Add or Remove Programs window, select the following items one at a time, and choose the Change/Remove button after each selection:

- SAP Business One Server Tools
- SAP Business One Client
- SAP Business One Server
- Data Transfer Workbench
- SAP Business One SDK

2. To remove the DI API:
   - If you installed the DI API as part of the SAP Business One client installation, the system removes the DI API when you uninstall the SAP Business One client.
   - If you installed the DI API using the manual setup program in the B1_SHR/B1DIAPI folder, you must remove it by selecting SAP Business One DI API in the Add/Remove Programs window.

Result

SAP Business One entries no longer appear in the Programs menu and any shortcuts that you may have on the Microsoft Windows desktop are removed.

You can now do the following:

- Manually delete the SAP Business One folders in Microsoft Windows Explorer.
- Remove SAP Business One databases using your database management application.

3.7. Uninstalling Integration Component for SAP Business One

This procedure enables you to uninstall integration component for the SAP Business One application.

Procedure

1. In the Microsoft Windows environment, choose Control Panel → Add/Remove Programs.
2. From the following list, select the SAP Business One integration component that you want to remove:
   - SAP Business One integration Server
   - SAP Business One integration EventSender
   - SAP Business One integration DI Proxy
3. Choose Remove.
4. To confirm, choose OK.
4. Performing Post-Installation Activities

This section describes the activities you are required to perform immediately after installing SAP Business One. The activities include the following:

- Configuring services
- Installing the license key
- Assigning SAP Business One add-ons
- Installing the Outlook integration standalone version
- Setting up the dot matrix printer

4.1. Configuring Services

You must configure the services you have installed if they are to operate properly.

**Note**

The first time you configure any service in the service manager, you need to specify the site user password. This is not for authentication purposes, but to obtain the database password. Once you enter the site user password once, you do not have to enter it again when you configure other services.

**Example**

You have a landscape of 10 computers, each with a server and server tools. The backup service is installed on all of the server tools, and the license server is installed on computer No. 1. If you go to configure the backup server on computer No. 5, for example, you have to specify the site user password (because it is the first time you are using the service manager). Later, when you want to configure the backup service on another computer, no password is needed, even if the computer is restarted.

SAP Business One services include the following:

- SBO Backup
- SBO DI Server
- License Manager
- SBO Mailer
- Fax service

### 4.1.1. SBO Backup

This optional service performs database backups and lets you schedule automatic backups.

For more information, see [Configuring Backup Services](#).

### 4.1.2. SBO DI Server

This service is optional for your installation. It enables multisession access to, and manipulation of, the SAP Business One company database. To use it, you are required to have a special license.

For more information, see the SDK Help Center.
4.1.3. License Manager
This mandatory service manages the application license mechanism.
For more information, see the section Configuring the License Manager below.

4.1.4. SBO Mailer
This optional service enables you to send e-mail and fax messages from SAP Business One.
For e-mail messages only, you can install this service on the SAP Business One server or on one of
the workstations. For more information, see Configuring SBO Mailer.

4.1.5. Configuring the License Manager
Configuring the license manager is essential for the successful operation of SAP Business One. This
service manages license requests and lets you install a license key, which is required to run SAP
Business One, according to your contract.
For new installations, you can use the application for a period of 31 days without a license key. After
that period, the SAP Business One application needs a license key to run.
We strongly recommend that you request a license key immediately after installing the application.

Procedure
1. To open the SAP Business One Service Manager window, in the Microsoft Windows task bar
double-click (SAP Business One Service Manager).
   Alternatively, choose Start → Programs → SAP Business One → Server Tools → Service
   Manager.
2. In the Service dropdown list, select License Manager and choose the Settings button.
3. The *General Settings* window shows the details of the license service computer. Choose the *Connect* button.

![General Settings Window](image)

**Note**

If you installed the license service on the SAP Business One server, SAP Business One sets `localhost` by default. Otherwise, enter a name or IP address for the computer. We recommend that you do not change the default value for the *Port Number* field.

**CAUTION**

If you installed a firewall on the license service computer, make sure that the firewall is not set to port 30000; otherwise, the license service cannot work.

If you are using Port X, make sure that you open Port X and Port (X+1) in the firewall. For example, if you are using port 10000, make sure to also open port 10001.

4. To save your settings and close the *General Settings* window, choose the *OK* button. If you already have a license key file, you can continue to [Installing the License Key](#).
5. Choose (Play) and select the checkbox: Start when operating system starts.

4.1.6. Configuring the Fax Service

SAP Business One offers fax services through Microsoft Fax service. For more information, see Configuring Fax Services.

4.1.7. Configuring Backup Services

The SAP Business One backup service provides automatic backups of company databases to specified directories.

This service also backs up the following application folders:

- Attachments
- Bitmap files
- Excel files
- Word documents

Note
For more information about restoring the application folders, see the section: Restore.

Procedure

To specify SAP Business One application folder paths, do the following:

1. In the SAP Business One Main Menu, choose:
   Administration → System Initialization → General Settings

2. In the General Settings window, on the Path tab, use the Browse buttons to specify the relevant folder paths.

3. Choose the Update button and then choose the OK button.

Note
To ensure that the backup service can access application folders, specify a computer or computers other than the computers where the SAP Business One server or client is installed.
Recommendation

We recommend the best practice of using the SAP Business One shared folder (B1_SHR) for application folder backups.

The process of configuring an automatic backup service entails performing the following steps:

- Setting backup folders
- Connecting to the database
- Selecting databases
- Scheduling backups

Procedure

1. To set backup folders, proceed as follows:
   a. To open SAP Business One Service Manager, in the Windows notification area, double-click (SAP Business One Service Manager).
      Alternatively, choose Start → Programs → SAP Business One → Server Tools → Service Manager.
      In the Service dropdown list, select SBO BackUp and choose the Settings button.
   
   ![SAP Business One Service Manager](image)

   b. In the General Settings window, do the following:
      - In the Back Up directory field, choose "..." (Browse) to select the destination of the backup files. Define an actual path.
      - In the Back Up Temp field, choose "..." (Browse) to select a temporary backup folder to hold the backup file, in case the backup process fails to copy the file into the specified backup folder.

   ![General Settings](image)

   c. Choose the OK button.
d. In the SAP Business One Service Manager window, choose (Play) and select the checkbox: Start when operating system starts.

2. To connect to the database, proceed as follows:
   a. In the SAP Business One Service Manager window, choose the Connection button.

   ![SAP Business One Service Manager window]

   b. In the Site User Password window, enter the license server address and the site user password, and then choose the OK button.

   **Note**

   The site user password is only required the first time you connect to a service from SAP Business One Service Manager.

   ![Site User Password window]

   c. In the Connection Settings window, select the database type and the database computer.

   d. To save your settings and close this window, choose the OK button.

3. To select the databases, proceed as follows:
a. In the SAP Business One Service Manager window, choose the Database button.

b. In the Select databases to use window, select the databases you want to back up and choose the OK button.
4. To schedule the backups, proceed as follows:
   a. In the SAP Business One Service Manager window, choose the Schedule button.

   ![SAP Business One Service Manager window](image)

   b. In the Scheduler – SBO BackUp window, select one of the following scheduling options for performing backups:
      - **On Specific Date** defines a backup for a specific date and time.
      - **Daily** sets a backup for a fixed hour of each day.
      - **Weekly** sets a backup for a fixed hour on a fixed day of each week.
      - **Monthly** sets a backup for a fixed hour on a fixed day of each month.

   ![Scheduler – SBO BackUp window](image)

   c. Choose the OK button. If you do not need to configure other services, close the SAP Business One Service Manager window.

4.1.8. Configuring SBO Mailer

The process of configuring SBO Mailer comprises the following procedures:

- Starting SBO Mailer
- Defining the mail settings
- Connecting to the database
- Selecting databases
- Setting the mail processing schedules
**Prerequisites**

You have installed the SBO Mailer service.

For information, see [Installing the SAP Business One Server](#).

**Procedure**

1. Start SBO Mailer, as follows:
   a. To open the **SAP Business One Service Manager** window, in the Windows system tray, double-click `SAP Business One Service Manager`.
      Alternatively, choose `Start ➔ Programs ➔ SAP Business One ➔ Server Tools ➔ Service Manager`.
   b. In the **Service** dropdown list, select `SBO Mailer`.
   c. Choose (Play) and select the checkbox: *Start when operating system starts*.

2. Define mail settings, as follows:
   a. In the **SAP Business One Service Manager** window, choose the **Settings** button.
The *General Settings* window appears.

b. In the *General Settings* window, do the following:

- In the *SMTP Server* field, enter the name or IP address of your outgoing mail server. To make changes in this field later, you must stop the Mailer service.
- In the *SMTP Port* field, specify the port number for mail services.
- In the *Encoding* field, select the language for e-mail text.
- If you are using a right-to-left language, to define the direction of the e-mail text, select the checkbox: *HTML direction right-to-left*.
- To include the subject line in the body of the message, select the checkbox: *Include Subject in Message Body*.
- Under *Fax Settings*, select the required fax service. For more information, see [Configuring the Fax Service](#).

**Note**

In the *General Settings* window, enter the details according to your company settings.
3. To connect to the database, proceed as follows:
   a. In the SAP Business One Service Manager window, in the Service dropdown list, select SBO Mailer, and then choose the Connection button.
   ![SAP Business One Service Manager window](image)
   b. In the Connection Settings window, do the following:
      - To connect to a database, specify a valid user name and password.
      - To use Windows authentication, select the Use Trusted Connection checkbox.
      - Choose the OK button.
4. To select a database, proceed as follows:
   a. In the Service Manager window, from the Service dropdown list, select SBO Mailer, and then choose the Database button.
   ![SAP Business One Service Manager window](image)
   b. In the Select databases to use window, select the databases for which you want to enable mailing services, and then choose the OK button.
c. In the SAP Business One Service Manager window, from the Service dropdown list, select SBO Mailer, and then choose the Settings button.

![SAP Business One Service Manager window](image)

d. In the General Settings window, in the Mail Settings area, select components according to your network definitions, and then choose the OK button.

**Note**

As of the SAP Business One 2007 A SP01 release, the SAP Business One Service Manager window does not provide access to SBO Mailer e-mail signature settings. To access these settings, from the SAP Business One Main Menu, choose Administration → System Initialization → E-Mail Settings.
To set the mail processing schedules, proceed as follows:

a. In the SAP Business One Service Manager window, in the Service dropdown list, select SBO Mailer, and then choose the Schedule button.

b. In the Scheduler – SBO Mailer window, select one of the following options:
   - *By Intervals* sets mail and fax processing to start regularly every \( x \) hours and \( y \) minutes.
On Specific Date defines mail and fax processing for a specific date and time.

Daily sets mail and fax processing for a fixed hour of each day.

Weekly sets mail and fax processing for a fixed hour on a fixed day of each week.

Monthly sets mail and fax processing for a fixed hour on a fixed day of each month.

5. Choose the OK button to return to the SAP Business One Service Manager window.

4.1.8.1. Configuring Fax Services

SAP Business One offers fax services through Microsoft Fax Services. For more information, see How To Install and Configure Microsoft Fax Services in SAP Channel Partner Portal at http://channel.sap.com/sbo/documentation.

This service can send several attachments as separate fax messages, added to a fax message. For supported file types, see the Microsoft documentation at www.msdn.microsoft.com.

4.1.8.2. Troubleshooting

The following troubleshooting information may be required when configuring the mail services:

1. Ensure that you have already set up an e-mail account for the SAP Business One users on your mail server. To verify the connection with the mail server, choose the Test Connection button.

2. The mail service checks the connection with the specified mail server and e-mail account and displays an appropriate message.

3. If the SMTP server requires some authentication, for example, if the SMTP server is configured to accept only logon-authenticated mails, but you selected the No Authentication option, the test connection should be successful.

4. To check whether the connection to the SMTP server works, send a test e-mail. If the connection fails, ensure that you have done the following:
   - Entered the correct name of your mail server
   - Entered the correct user ID and password
   - Restarted the SBO Mailer service after changing any of the settings
4.2. Technical Configurations

In SAP Business One, you can process the following technical data configurations:

- Use the SAP Business One Service Manager to configure the license manager. For more information, see Configuring the License Manager.

- After you have installed SAP Business One and logged on to the application for the first time, you are required to provide the license server address and port number in the License Server Selection window.

- In the SAP Business One toolbar, you can check the log configurations by choosing Help → Support Desk → Logger Setting. You can see the relevant configuration log file under: ...

4.3. Installing the License Key

To use your SAP Business One application according to your contract, you are required to install a license key assigned by SAP.

You also must install a new license key whenever any of the following occurs:

- You have additional users or components.
- The hardware key changes.
- The current license key expires.
- You have a new installation of SAP Business One.

To avoid changing the hardware key accidentally, do not perform the following actions on the license server computer:

- Formatting the computer and reinstalling Microsoft Windows using another product key for Windows
- Changing the computer name
- Changing the domain (hardware key does not change back when you return to the previous domain)

The following actions are safe and do not change the hardware key:

- Adding a new user logon
- Changing the computer date or time

Procedure

1. To open the SAP Business One Service Manager, in the Windows notification area, double-click

   Alternatively, choose → Start → Programs → SAP Business One → Server Tools → Service Manager.
In the SAP Business One Service Manager window, in the Service dropdown list, select License Manager and choose the Settings button.

2. In the General Settings window, do the following:
   - Enter the computer name or IP address of the computer on which the server tools were installed.
     
     **Note**
     
     Use `localhost` only in standalone installations.
   - To install the license key file, choose `...` (Browse) and select the `.txt` file you received from SAP.
3. Choose the *Import License File* button.
4. To save your settings and close the *General Settings* window, choose the OK button.
5. To close the *SAP Business One Service Manager* window, choose the OK button.

### 4.4. Assigning SAP Business One Add-Ons

SAP add-ons are additional components or extensions for SAP Business One. The following add-ons are included in the automatic registration:

- Copy Express
- Datev FI Interface
- ELSTER Electronic Tax Return
- Fixed Assets
- Intrastat
- Format Definition
- Microsoft Outlook integration
- Payment Engine
- Screen Painter
- Bank Transaction Handling Facility (BTHF)
- XL Reporter

Installing both the server and client applications also registers the SAP add-ons and makes them available for installation from the SAP Business One application.

**Prerequisites**

- You have a Professional license from SAP.
- You have installed Microsoft XML 3.0 Service Pack 4 on your workstation. To ensure that this software is installed on the hard drive of the workstation, check that the `msxml3.dll` file is saved in the `system32` directory in the main Windows directory.
- If you chose *Custom* for the installation of server components, ensure that *SAP Add-ons* is selected in the *Select Features* window.
- You must have Power User or Administrator rights, especially in the terminal server environment.

The following table displays the SAP Business One add-ons and their prerequisites.

<table>
<thead>
<tr>
<th>Add-On</th>
<th>Prerequisites</th>
</tr>
</thead>
<tbody>
<tr>
<td>Payment Engine</td>
<td>Inbound Functionality is activated only when the <em>Bank Statement Processing</em> checkbox is deselected.</td>
</tr>
<tr>
<td>Screen Painter</td>
<td>You have installed Microsoft .NET Framework 2.0 on the SAP Business One workstation intended to run Screen Painter.</td>
</tr>
<tr>
<td>Copy Express</td>
<td>To be able to install the Copy Express add-on successfully, you must grant write permission to all users in the SAP Business One <code>B1_SHR</code> server folder.</td>
</tr>
<tr>
<td>Format Definition</td>
<td>You have installed Microsoft .NET Framework 2.0.</td>
</tr>
</tbody>
</table>
## Prerequisites

<table>
<thead>
<tr>
<th>Add-On</th>
<th>Prerequisites</th>
</tr>
</thead>
<tbody>
<tr>
<td>BTHF</td>
<td>You have installed Microsoft .NET Framework 2.0.</td>
</tr>
</tbody>
</table>
| Fixed Assets | • For customers using Fixed Assets version 2005 SP0 or lower, the fiscal year definition must consist of 12 active periods. Fixed Assets accepts a noncalendar fiscal year only if the customer has defined 12 periods, with each period starting on the first day of the period.  
  For customers using Fixed Assets version 2005 SP1 and higher, the system now supports the use of nonmonthly accounting calendar fiscal year definitions such as a 4-4-5 accounting calendar, and it does not require the fiscal year definition to consist of 12 active periods, as required in 2005 SP0 or in earlier versions.  
  • During its initial start-up, Fixed Assets tries to add records to the item master data table. To add an item, you must provide an item group and two valid VAT groups.  
  Since it is the only one that exists in SAP Business One by default, "100" is used as the item group.  
  • Fixed Assets uses country-specific VAT codes for all localizations it supports; see SAP Note [770851](https://support.sap.com).  
  **CAUTION**  
  If you delete the country-specific tax groups or the item group “100” from your company database, you cannot initialize Fixed Assets. |
| Microsoft Outlook integration | You have installed the following on your workstation:  
  After installing Microsoft Outlook, you created an e-mail account for sending and receiving e-mails.  
  Microsoft Outlook is set as your default mail client. To check your default mail client, open the Control Panel window, and choose Internet Options. On the Programs tab, make sure that in the E-mail field, Microsoft Outlook is selected.  
  You have closed Microsoft Outlook, Word, and Excel on the workstation. |
| Datev FI Interface | You have created a new company to work with the DATEV add-on and deselected the checkboxes: Copy User-Defined Fields and Tables and Copy User-Defined Objects.  
  The DATEV add-on may not work with demo databases. |
4.4.1. Constraints

When you run SAP Business One 8.81, you can use only SAP Business One add-ons from Release 8.81. These add-ons can run only on SAP Business One 8.81.

The add-ons run under the SAP Add-Ons license, which is included in the Professional User license.

Procedure

For information about how to assign SAP add-ons, see the Assigning Add-Ons online help document.

You can find the online help document at the following locations:

- Partners: SAP Channel Partner Portal at http://channel.sap.com/sbo/documentation
5. Upgrading SAP Business One

To upgrade your SAP Business One application to version 8.81 and run it successfully, you must do the following:

1. Upgrade your SAP Business One successfully to 8.81
2. Renew your SAP Business One license to 8.81
3. Import the 8.8 license file

**Recommendation**

Before upgrading to SAP Business One 8.81, we recommend that you read the material about the Accelerated Upgrade Program (AUP) that is available in the SAP Service Marketplace. AUP is a standard and documented upgrade methodology, which includes tools, templates, and best practice recommendations for efficiently handling SAP Business One upgrades. The Accelerated Upgrade Program (AUP) is available at [http://www.channel.sap.com/sbo/aup](http://www.channel.sap.com/sbo/aup).

**Note**

For the latest information about upgrade issues that may not appear in this guide, see SAP Note [1476795](http://www.sap.com/notes/1476795).

5.1. Upgrade Methods

You can use either of the following upgrade methods to upgrade previous SAP Business One versions to 8.81.

- Use the SAP Business One upgrade wizard to upgrade your SAP Business One to a higher major version, a support package, or a new patch above the SAP Business One 8.8 release. If any of the upgrade steps fail, you can use the restoration mechanism to reverse all the database changes made to your SAP Business One landscape by the wizard, and return to the SAP Business One version before the upgrade.

**CAUTION**

To detect any errors or warnings that may arise in the SAP Business One upgrade process, it is mandatory that you perform a trial run of the SAP Business One upgrade wizard up to and including step 12 as described in the procedure below. The results of the pre-upgrade checks in the upgrade wizard indicate where you may need to correct any errors before performing the actual upgrade. If no issues are found, you may continue with the upgrade procedure.

- Upgrade directly from the upgrade package folders.

You can use the upgrade files in the upgrade package to upgrade the components you want, although this method is not recommended and only advanced users can use it.

**CAUTION**

If you want to upgrade the SAP Business One server or company database, you can run the upgrade wizard **ONLY** on the SAP Business One server computer.

**CAUTION**

The upgrade files listed in the upgrade package do not form a whole set of the upgrade process files. They are provided for advanced users only. For more information, see the

**Note**
When you perform an upgrade from SAP Business One 2005 A SP01, 2007 A, or 2007 B to SAP Business One 8.81, your previous SBO Mailer e-mail signature settings are automatically copied to the Common database and appear on the Common E-Mail Signature tab of the E-Mail Settings window.

You can access these settings from the SAP Business One Main Menu → Administration → System Initialization → E-Mail Settings.

## 5.2. Supported Releases for Upgrade

The following releases are currently supported for upgrade to 8.81:

- SAP Business One 2005 A SP01
- SAP Business One 2005 B
- SAP Business One 2007 A
- SAP Business One 2007 B
- SAP Business One 2007A SP01
- SAP Business One 8.8

For more information about upgrade releases and specific patches, see the collective SAP Note for upgrade issues: 1476795.

**Note**
To upgrade an SAP Business One version that is lower than 2005 to 8.81, first upgrade the current version to 2005 A SP01, 2005 B, or 2007 and then perform the upgrade to 8.81.

### Prerequisites

- You have downloaded the upgrade package from SAP Service Marketplace. For more information, see Downloading the Upgrade Package.
- You have made sure that company databases are not connected to either SAP Business One clients or SQL Server clients.
- You have the SAP Business One 8.8 license file available. You need this license file for connecting your company after the upgrade process is finished. If you do not import a valid license file after the upgrade process, you cannot work with your company.
- You have Administrator rights on the computer that runs the SAP Business One upgrade wizard.
  
  To check if you have Administrator rights on your computer, proceed as follows:
  
  a. On your desktop, right-click the My Computer icon and choose Computer Manage → Local Users and Groups.
  
  b. Choose Groups → Administrators.
- The SBO–COMMON database is installed on the server.

**Note**

The SBO–COMMON database that you have installed on your computer must not be a later release than the upgrade package, or the upgrade cannot proceed.
• If any components of SAP Business One integration for SAP NetWeaver (B1iSN) were previously installed on your server, you have uninstalled them manually before installing integration component delivered with SAP Business One 8.81. This step is required due to compatibility reasons. For more information about uninstalling components of B1iSN, see the *SAP Business One integration for SAP NetWeaver Installation and Upgrade Guide*.

• You have installed the Crystal Reports software.

**Note**

If you want to install the Crystal Reports software after upgrading the SAP Business One client, you may need to run the Crystal Reports integration package script. For more information, see [Running the Crystal Reports Integration Package Script](#).

For more installation information about installing the Crystal Reports software, see [Installing Crystal Reports for SAP Business One](#).

• During the upgrade of SAP Business One, you have the option of installing remote support platform for SAP Business One. For more information about installing remote support platform for SAP Business One, see the *Administrator's Guide to Remote Support Platform for SAP Business One* document under: \Documents\Remote Support Platform on the SAP Business One product DVD or on the dedicated landing page in SAP Channel Partner Portal at [http://channel.sap.com/sbo/rsp](http://channel.sap.com/sbo/rsp).

## 5.3. Upgrade Process

Upgrading SAP Business One consists of the steps outlined below. Each of these steps is explained in more detail in the following subsections.

1. Run the SAP Business One upgrade wizard to perform the following operations:
   a. Validate the license server
   b. Select components for upgrade

   **Recommendation**

   Upgrade all the server components at one time, and not separately. Otherwise you may have problems fixing certain errors in the pre-upgrade check.

c. Select a database for upgrade

d. Perform pre-upgrade checks

e. Specify a backup location (only occurs when database components are selected for upgrade)

   f. Run the upgrade process

   g. Restore (only occurs when upgrade fails)

2. Upgrade SAP Business One client workstations.

3. Upgrade SAP Business One add-ons.

   **Note**

   You cannot use the SAP Business One upgrade wizard for this step.
5.3.1. Downloading the Upgrade Package

Download the SAP Business One upgrade package from SAP Service Marketplace, as follows:

2. To download an upgrade, click SAP Business One Products in the left navigation panel and choose Updates.
3. Navigate to and select the relevant download object.
4. Before starting the download, read the Info file for the selected download object.
5. Extract the downloaded file to your computer.
6. Before you start an upgrade, read the section Running the SAP Business One Upgrade Wizard.

If you experience problems when downloading software, send a message to SAP as follows:

2. In the left navigation panel, click Partner Support Dashboard.
3. Use SAP Message Wizard to write the message and assign it to component SBO-CRO-SUP.

5.3.2. Running the SAP Business One Upgrade Wizard

Procedure

1. In the upgrade root folder, double-click the Upgrade.exe file.
2. To continue with the upgrade, in the Welcome window, choose the Next button.
3. In the License Server window, specify the license server that you want to validate.

CAUTION

If you are choosing a remote license server, make sure it is the 8.81 release; otherwise, the upgrade cannot proceed.
To continue, choose the Next button.

The wizard starts to validate your license server. If you have now upgraded your license server to the 8.81 release, go on to step 4; otherwise, go to step 5.

**Note**

If the wizard detects a license server, but has problems communicating with that license server, the following reasons may be causing the communication problems:

- License server is not launched
- License server cannot be connected

To continue with the wizard, you must fix the connection problems.
4. In the **License Server Validation** window, specify the site user password, and then choose the **Next** button.

5. In the **Connection Settings** window, specify the following fields of your SAP Business One server:
   - **Server Type**: Select a Microsoft SQL Server type from those you installed.
   - **Server Name**: Specify the computer name on which you installed Microsoft SQL Server 2005 or 2008.

   **CAUTION**

   In the **Server Name** field, make sure of the following:
   - The name of the computer on which you installed Microsoft SQL Server does not contain any special characters, such as:
     - `&`
     - `<`
     - `>`
     - `"`
     - `'
   - Do not use the following entries: `localhost`, `(local)`, `.`, and `127.0.0.1`.

   To check or correct the name of your computer, proceed as follows:
   a. Choose **Start → Control Panel → System**.
   b. In the **System Properties** window, select the **Computer Name** tab.
   c. In the **Computer name** field, check the computer name.
   d. To correct the computer name, choose the **Change** button.
e. In the Computer Name/Domain Changes window, specify a new name for the computer, and then choose the OK button.

   - Database User ID: On the Server Roles properties tab in Microsoft SQL Server Management Studio, specify a user enabled with sysadmin.
   - Database Password: Specify the password of your database user.

Note

If you have problems setting the server, make sure that the name format of your computer is the same as the name format of your license server.

To connect to your SAP Business One server, choose the Next button.

6. In the Component Selections window, select the checkbox of each component that you want to upgrade.

   If a component has already been upgraded to the current version or release, its checkbox is enabled and not selected. You can select it again to overwrite the component instance.

   **Recommendation**

   We recommend that you upgrade all the server components at one time, and not separately. Otherwise you may have problems fixing certain errors in the pre-upgrade check.

   Choose the Next button.

   **Note**

   To upgrade all SAP add-ons, select the Add-Ons checkbox. Then all the new releases of add-ons, including the Microsoft Outlook integration server installer add-on, are automatically registered on the SAP Business One server and new installers are uploaded to the server. For more information about upgrading add-ons, see Upgrading SAP Add-Ons.
Note

If the Common Database checkbox is inactive and not selected, it means that the SBO-COMMON database is not on your computer.

Note

The license server, as part of the server tools, must be upgraded first. If your license server has not been upgraded to 8.81, the wizard automatically selects the Server Tools checkbox.

Note

If the installation of remote support platform for SAP Business One fails, this does not affect the successful installation SAP Business One.

The installation of remote support platform for SAP Business One does not impact SAP Business One business processes. There is no technical dependency between SAP Business One and remote support platform for SAP Business One.

Note

The upgrade wizard upgrades client components, but it does not upgrade client workstations. For more information about upgrading SAP Business One clients, see Upgrading SAP Business One Client Workstations.

7. In the Database Selections window, do the following:
   - Select the checkboxes of the databases that you want to upgrade.
   - In the User ID and Password fields, specify the SAP Business One super user account and password.
   - Select the system behavior in case a company database upgrade fails:
     - To stop the upgrade process and continue to the Restoration screen, deselect the Ignore unsuccessful upgrade of a company database and continue upgrade process checkbox. This is the default and our recommended setting.
To upgrade the remaining company databases and software components, and restore only those databases that could not be upgraded, select the `Ignore unsuccessful upgrade of a company database and continue upgrade process` checkbox.

Choose the Next button.

**Note**

If you have selected the `Common Database` checkbox in the previous Component Selection window, the checkbox is selected and inactive now.

The wizard checks the version and the localization of the database, as well as the user ID and the password that you have specified.

- In each of the following cases, the status of the database displays as `Not Ready`, and the wizard disables the checkbox of the database:
  - The wizard does not support the version of the company database.
  - The company database is already of the latest version.
  - The wizard does not find the localization of the company database from the locale list of the common database.

- In each of the following cases, the status of the database displays as `Not Ready`, and the checkbox of the database is active:
  - The wizard finds more than one connection to the database.
  - The user ID or the password that you have specified is incorrect.
  - Superuser is locked or no superuser is provided.
8. If all the selected databases have the status Ready, choose the Next button.

Note
If any of the selected databases has the status Not Ready, the wizard disables the Next button.

Choose the Not Ready link to see the details. You cannot proceed to the next step until you have fixed the problem.

To proceed with the upgrade while ignoring the Not Ready databases, deselect these databases and choose the Next button.

9. In the Pre-Upgrade Check window, choose the Next button.

The SAP Business One upgrade wizard performs a set of pre-upgrade checks on each database to ensure its readiness for the upgrade and to reduce the possibility of upgrade failure.

Note
For the latest detailed information about all pre-upgrade checks, see SAP Note 1357462.

10. In the next window, the wizard first checks the SBO–COMMON database and then checks each of the rest of the databases one by one.

Note
If the SBO–COMMON database does not pass the checks, the wizard does not continue with the rest of the checks.
The pre-upgrade test checks the selected components and databases one by one.

After the processing, you can learn more from the following:

- **Details**: Click this link to view the processing details of each component and database.
- **Open Log File**: Choose this button to open a log file window that contains all testing records.

11. After finishing the checks on all the databases, choose the **Details** hyperlink to access detailed information about the identified warnings and errors.

   - If the wizard identified errors:
     
     a. Review all errors and click on the hyperlinks to access the instructions described in the relevant SAP Notes or in the corresponding help file.

     **CAUTION**
     
     To continue the upgrade, you must fix all errors.

     b. Choose the Return button to return back to the pre-upgrade test results screen.

   - If the wizard identified warnings:
     
     a. Review all warnings and click on the hyperlinks to access the instructions described in the relevant SAP Notes.

     b. After carefully reading the instructions, you can decide to confirm the warning by clicking the corresponding checkbox.

     **Note**
     
     To continue the upgrade, you must confirm the warnings.

12. In the **Upgrade-Backup Settings** window, specify the location where you want to store the backup files:
To use the default backup path configured in SQL Server, choose *Use the Default SQL Server Backup Location*.

To use a location on the database server, choose *Browse directories on database server* and click the *Browse* button to choose a directory.

To use a network drive, choose *Enter a network path* and specify the path.

After you specified a location for the backup, the system displays the required space and the available space for the following:

- The databases backups
- The increased size of the databases after the upgrade. The size of the databases can increase to up to twice the size of the original databases.
- The backups of any other files generated during the upgrade

13. In the *Upgrade Summary* window, the wizard displays the operations that will be carried out for each component and database.
14. The *Upgrade in Process* window displays the upgrade progress of each component and database.
The InstallShield Wizard that runs from the SAP Business One upgrade wizard indicates that it is installing various components. However, all references to installation should be understood as upgrade.

15. According to the upgrade results, you see one of the following windows:

- **Upgrade Result: Upgraded** window: If the upgrades of all components and databases succeed, the wizard opens this window.
  - To continue, choose the Next button.

  To view the details of the upgraded components, click the Details link. The Upgrade Result – Details window appears.
If the upgrade of any component or database fails, the wizard opens this window.

To continue with the restoration step of the rollback process, choose the Next button, and then proceed to the section Restoring Components and Databases.
To see the details of the failed components, click the Details link.

In the Congratulations window, choose the Finish button close the wizard. You can proceed to Upgrading SAP Add-Ons.
5.3.3. Restoring Components and Databases

If the upgrade process fails, the SAP Business One upgrade wizard restores the databases. Software components must be restored manually.

Note
The procedure below continues from step 15 in the previous section, Running the SAP Business One Upgrade Wizard. It is relevant only for cases where the upgrade has failed.

Procedure

To start the restore procedure, do the following:

1. In the Restoration window, choose the Next button.
   The wizard starts to restore components one after another.

Note
The SAP Business One upgrade wizard restoration only reverses all the changes made to the following database components:

- Common database
- Company databases
  You can select which databases should be restored.
- Add-ons
- Help File

The components that cannot be restored are:

- Server Tools
- DTW
- DI API
- Microsoft Outlook integration
2. You can see one of the following windows as the restoration result:
   
   - **The Restoration Result: Restored** window appears if the restoration is successful. To complete the restoration, do the following:
     
     i. In the **Restoration Result: Restored** window, choose the Next button.
ii. In the Congratulations window, choose the Finish button to complete the restoration process.

If the restoration fails, the Restoration Result: Failed window appears. To complete the restoration, do the following:

i. In the Restoration Result: Failed window, choose the Next button.
ii. In the displayed window, choose the Finish button to exit.

**Note**

If the restoration fails, to roll back SAP Business One to the version before the upgrade, you have to do a manual restoration.

### 5.3.4. Upgrading SAP Business One Client Workstations

After running the SAP Business One upgrade wizard, to complete the SAP Business One upgrade, you have to manually upgrade your SAP Business One client workstations. You can perform a client upgrade from either of the following:

- From the client workstation
- From the `B1_SHR` folder

#### 5.3.4.1. Upgrading from the Client Workstation

After you open your SAP Business One client following a server upgrade using the upgrade wizard, you need to perform an upgrade of the client.

**Procedure**

1. To upgrade the SAP Business One client, choose Start → All Programs → SAP Business One → SAP Business One.
2. In the logon screen, enter your user ID and password.
3. In the System Message window shown below, do one of the following:

   - To start the upgrade of the client workstation, choose the OK button.

   After several minutes, the following windows appear:
To exit SAP Business One without performing an upgrade, choose the Cancel button.

**CAUTION**

If you choose the Cancel button, you cannot log on to your SAP Business One client.

In the SAP Business One Client InstallShield Wizard window, a progress bar appears, showing the progress of the installation.

**Note**

This is a silent upgrade. In other words, the upgrade proceeds automatically and you do not need to provide any input at this stage.

The SAP Business One DI API – InstallShield Wizard window appears. As with the previous screen, the DI API upgrade proceeds automatically.
4. In the License Server Details screen, do one of the following:

   o Select the first radio button and enter your license server name and port.

     **Recommendation**
     We recommend that in the Port field you enter 30000.

   o Select the Shared Folder Location radio button and choose the Browse button to specify the folder where the license server is located.
5.3.4.2. Upgrading from the B1_SHR Folder

After performing a server upgrade with the upgrade wizard, you can upgrade each client workstation from the B1_SHR folder. This folder is usually located in the directory path shown below:

\C:\Program Files\SAP\SAP Business One Server\B1_SHR

Procedure

To search your computer for the B1_SHR folder:

2. In the Run window, in the Open field, enter:
   \\<computer name>\B1_SHR
3. Choose the OK button. The B1_SHR folder is displayed.

Note

The client upgrade procedure from the B1_SHR is the same as the client installation procedure. For full instructions, see Installing the SAP Business One Client.

5.3.5. Upgrading SAP Add-Ons

When you select the Add-On checkbox in the Component Selections window of the upgrade wizard, the following occurs:

- New releases of all SAP add-ons, including the Microsoft Outlook integration server installer add-on, are automatically registered on the SAP Business One server.
- New installers are uploaded to the server during the upgrade of the SBO-COMMON database.

Add-ons that were already installed and assigned to a company are reregistered with new releases and assigned to the same company.

Upon the next logon to a company assigned with add-ons, installers for the new add-on releases run automatically.

5.3.5.1. Upgrading the Intrastat Add-On

If you are upgrading an Intrastat add-on from an Intrastat version that is lower than 2007 A, proceed as follows:

1. Choose to copy the user-defined fields (UDFs) from the item master data and business partner master data to new UDFs in Intrastat 8.8.
2. Choose to keep in or delete from Intrastat 8.8 all existing UDFs of Intrastat versions lower than 2007 A.
5.3.6. Upgrading the Online Help

When you select the Help checkbox in the Select Features window of the upgrade wizard, new versions of the online help files are saved on the SAP Business One server.

The next time users access the online help on their client workstation, they can choose whether to download the new help version that was found on the server or whether to use the old help version.

5.3.7. Troubleshooting Upgrading SAP Business One with the Upgrade Wizard

- The shared folder B1_SHR on the SAP Business One server computer must exist with the shared settings.

- In the Database Server Name field in the Database Server Logon window, if specifying the computer name does not work, use the IP address of the server computer. Be sure the format is consistent with what you have defined for the license server.

- When you perform an upgrade from SAP Business One 2005 A SP01 or 2007 A to SAP Business One 8.81, your previous SBO Mailer e-mail signature settings are automatically copied to the Common database and appear in the E-Mail Settings window, on the Common E-Mail Signature tab.

  To access these settings, from the SAP Business One Main Menu, choose Administration → System Initialization → E-Mail Settings.

- If you install the Crystal Reports software after upgrading the SAP Business One client, execute the SAP Business One Crystal Reports Integration Package.exe file in C:\Program Files\SAP\SAP Business One\Crystal.

  **Note**
  
  The folder path shown above may be different on your computer, depending on where you have installed SAP Business One and the Crystal Reports software. You can use the Microsoft Windows search facility on your computer to locate the folder and the file.

- To have SBO Mailer's signature copied after upgrade, do the following:
  
  a. To open the SAP Business One Service Manager window, in the Windows system tray, double-click (SAP Business One Service Manager).

    Alternatively, choose Start → Programs → SAP Business One → Server Tools → Service Manager.

  b. In the SAP Business One Manager window, in the Service dropdown list, select SBO Mailer, and then choose the Connection button.

  c. In the Connection Settings window, specify values in the DB Type and DB Server fields, and then choose the OK button.

  d. Log off SAP Business One and log on to SAP Business One again. You will find that the signature was copied.

5.3.8. Troubleshooting Upgrading Add-Ons

When upgrading add-ons in an upgraded company whose server name was previously something like (local), you may encounter a message about installation failure.

SAP Business One has introduced the license security mechanism, and we do not recommend that you specify a server name with something like (local). In this case, during an upgrade, the user
defines the server name as an IP address or a computer name. The application does not find the old (local) name of the upgraded company, which prevents old add-ons from being upgraded.

To solve this problem, proceed as follows:

1. Go to the \SAP Business One\ folder and locate the AddonsLocalRegistration.sbo file.
2. Change the server name of each related add-on to the new name specified in the license server.

   **Example**
   
   - Old name: `<Common ID="1" Name="(local)"/>`
   - New name: `<Common ID="1" Name="MyServerName"/>`

5.4. **Upgrading Directly from Upgrade Folders**

You can upgrade the components manually by running the files listed below from the upgrade folder.

   **Note**
   
   For information about the upgrade package, see [Downloading the Upgrade Package](#).

- **Server components:**
  
  - Server Tools: `\Packages\Server Tools\Setup.exe`
  - Common Upgrade: `\Packages\Upgrader Common\Upgrade.exe`
  - Help Upgrade: `\Packages\Upgrader Help\Upgrade.exe`
  - Add-Ons Upgrade: `\Packages\Upgrader AddOns\Upgrade.exe`

- **Client components:**
  
  - Mail and Fax Service: `\Packages\Server Tools\Setup.exe`
  - SDK: Manually uninstall and then upgrade using the SDK InstallShield installer under: `\Packages\SDK\Setup.exe`
  - Data Transfer Workbench – Manually uninstall and then upgrade by using the Data Transfer Workbench InstallShield installer under: `\Packages\Data Transfer Workbench\Setup.exe`
  - Microsoft Outlook integration add-on – Manually uninstall and then upgrade using the DTW InstallShield installer under: `\Packages\Outlook Integration standalone\Setup_OIS.exe`
6. Performing Database Maintenance Tasks

This section provides information about checking and maintaining your database system. Database activities depend on the nature of your organization’s day-to-day work. There are many factors influencing system performance, such as disk space availability, the number of transactions occurring each day, and so on. It is essential to perform daily and regular checks to ensure the efficient operation of SAP Business One. System performance depends on the correct administration of the database.

This section also lists all the stored procedures quoted in the SAP Business One 8.81 application.

6.1. Database Server Administration

This section provides basic information about the SQL Server environment, the way a database management system stores and accesses the data, and the database administration tool. The information comprises the following topics:

- Starting and stopping database services
- Performing weekly tasks
- Performing regular tasks
- Performing backups
- Performing restoration

6.1.1. Starting and Stopping Database Services

Occasionally, it is necessary to stop and start database services manually, for example, when you perform a complete backup of the database.

Procedure

- To stop database services:
  a. Verify that no clients are logged on to SAP Business One.
  b. To open SQL Server Management Studio, choose Start → All Programs → Microsoft SQL Server 2005 or Microsoft SQL Server 2008 → SQL Server Management Studio.
  c. In the Object Explorer window, right-click the database server computer on which your SAP Business One database is installed and choose Stop.

- To start database services:
  a. To open SQL Server Management Studio, choose Start → All Programs → Microsoft SQL Server 2005 or Microsoft SQL Server 2008 → SQL Server Management Studio.
  b. In the Object Explorer window, right-click the database server computer on which your SAP Business One database is installed and choose Start.

Note

If you are not able to log on to SAP Business One, and the dialog box for choosing a company appears with an empty list, check whether SQL Server is running.
If you log off the SQL Server services, all user processes are terminated, but the database services keep running.

### 6.1.2. Weekly Tasks

**Recommendation**

Perform the following tasks on a weekly basis, or more often if warranted by the database size and the volumes of daily or weekly transactions in SAP Business One.

The tasks are:

- Checking database consistency
- Running the *Update Statistics* command

#### 6.1.2.1. Checking Database Consistency

A database consistency check performs a thorough check of the entire database. It examines all tables in the database to ensure that index and data pages are linked correctly and that indexes are in the correctly sorted order. It also checks that all pointers are consistent and that the data information on each page and page offset is reasonable. The database consistency check enables early recognition of problems and prevents escalations and possible loss of data.

Ensure the following:

- Schedule consistency checks with the planning calendar.
- Run consistency checks on the weekends.
- Do not schedule any other task at the time of the consistency check run.

**Note**

On the SQL Server level, the SAP Business One database consistency check executes the `DBCC CHECKDB` command, which locks user tables, indexes, and system tables throughout the run.

In addition, it is I/O intensive and, therefore, should not run during normal operations, but at times when the system load is low.

#### 6.1.2.2. Running the Update Statistics Command

The *UPDATE STATISTICS* statement defines the storage requirements of tables and indexes as well as the value distribution of columns, and stores this information in the database catalog.

The *Optimizer* uses these values to determine the best strategy for executing SQL statements. Use the `sp_updatestats` procedure on all user-defined tables in the required database.

When the update statistics statement is executed, the following information about the table is stored in the database catalog:

- Number of rows
- Number of pages used
- Size of indexes
- Value distribution within columns or indexes
6.1.3. Regular Tasks

Performing scheduled tasks is essential for ensuring database availability and minimizing the risk of data loss. Perform the following tasks on a regular basis, as determined by your database size and transaction volumes:

- Verify that the database server is running
- Verify that the backups run successfully
- Check the database
- Shrink the transaction log
- Monitor disk space

6.1.3.1. Verifying that the Database Server is Running

You must complete this task every morning. SAP Business One clients cannot work if the database server is not running.

Procedure

Run the SAP Business One client and log on to your database server. If you can log on, the database server is running.

6.1.3.2. Verifying that Backups Run Successfully

Backups of your database are essential for recovering the SAP Business One system in case of failure. Use this procedure to verify that previous backups ran successfully.

Procedure

1. To open SQL Server Management Studio, choose Start → All Programs → Microsoft SQL Server 2005 or Microsoft SQL Server 2008 → SQL Server Management Studio.
2. Select the Management folder and check the SQL server logs.
3. Search for the last backup message.
4. Verify that the backup ran successfully and that the date fits the scheduled settings.

The following is an example of a successful backup message:

"Database backed up. Database: myDB, creation date(time): 2005/12/21(10:57:16), pages dumped: 502701, first LSN: 37211:18:108, last LSN: 37211:91:1, number of dump devices: 1, device information: (FILE=1, TYPE=DISK: ('E:\temp\bck\myDB')). This is an informational message only. No user action is required."

6.1.3.3. Checking the Database

The SQL Server database uses disk space to store the database data files and the daily transaction log files. If you do not set up a schedule for the backup of the transaction log, the log file can grow too large, causing a decline in system performance. Ultimately, this can stop the database system.

The transaction log should not fill more than 60-70% of the total available size. If it regularly exceeds this level between two backups, you must save the transaction log more frequently. You can determine in SQL Server Management Studio that the data file and transactional log file are set to grow automatically.

In addition, check the utilization of table space and the content of error logs on a regular basis.
Procedure

1. To check the size of the data file and the transaction log file, proceed as follows:
   a. Open SQL Server Management Studio by choosing Start → All Programs → Microsoft SQL Server 2005 or Microsoft SQL Server 2008 → SQL Server Management Studio.
   b. Select the database for which you want to check the transaction log size.
   c. Right-click the selected database and choose Reports → Standard Reports → Disk Usage. In the right pane, you can see the report.
   d. Verify that there is enough free space, based on your organization’s needs, for both the data file and the transaction log.

2. To set grow options for database files, proceed as follows:
   a. Open SQL Server Management Studio and select a database.
   b. Right-click the selected database and choose Properties.
   c. In the Properties window, from the menu on the left, choose Files. The database files appear in the right pane.
   d. In the Autogrowth field, set a value according to your organization’s needs.

3. To check error logs, proceed as follows:
   a. Open SQL Server Management Studio.
   b. Select the Management folder and check the SQL Server Logs folder.
   c. Check for error messages and verify that no problems have occurred.

6.1.3.4. Shrinking the Transaction Log

Manually shrinking the transaction log file frees up disk space and minimizes the risk of data loss. You can shrink it first virtually and then physically.

Shrinking the transaction log does not reduce the size of a physical log file. It removes enough inactive virtual logs to reduce the log file to the requested size.

Procedure

1. To open SQL Server Management Studio, choose Start → All Programs → Microsoft SQL Server 2005 or Microsoft SQL Server 2008 → SQL Server Management Studio.
2. Select the required system database.
3. Right-click the selected database and choose New Query. The right pane displays the Query window.
4. In the Query window, enter the following command:

   BACKUP LOG <sid> WITH NO_LOG

Where:

   <sid> = name of the database, for example, sbodemo_us

Right-click anywhere on the query tab and choose Execute.

This statement reduces the size of the logical log. It removes the inactive part of the log without making a backup copy and truncates the log.
Specifying a backup device is unnecessary because the log backup is not saved. After you back up the log using `NO LOG`, the changes recorded in the log are not recoverable. For recovery purposes, execute a manual backup of your database; see SAP Note 557412.

5. To reduce the size of the physical log file, enter the following command:

```
DBCC SHRINKFILE (<name_logfile>, <size>)
```

Where:

- `<name_logfile>` = the logical name of the shrunk file, for example, `sbodemo_us_log`
- `<size>` = the required size for the file in megabytes, expressed as an integer. If the size is not specified, `DBCC SHRINKFILE` reduces the size to the default file size, for example, 10 MB.

Right-click anywhere on the query tab and choose `Execute`.

**Note**

In SQL Server, a `DBCC SHRINKDATABASE` or `DBCCSHRINKFILE` operation attempts to shrink the physical log file to the requested size (subject to rounding).

### 6.1.3.5. Monitoring Disk Space

We recommend that you regularly check the amount of free space available on the disk.

### 6.1.4. Backup

This section provides an introduction to backups and information about the necessity of a backup strategy. Databases are always at risk of damage and it is vital to implement a security strategy. To keep the risk of data loss low, ensure that you develop a backup strategy that suits your business and the requirements of your customers. An important factor to consider is the volume of data that you process each day. In case of data loss, you are required to retrieve this data manually, back to the time of your last backup.

With SAP Business One, we recommend backing up your application database regularly.

**CAUTION**

SAP Business One can save the configuration data only when you have write and read access to the user profile folder.

### 6.1.4.1. Backup Strategies

To choose the appropriate backup-and-restore strategy, you need to identify the requirements for the availability of your data. Your overall backup strategy should define the type and frequency of backups and the nature and speed of the hardware.

Consider the complexity of each strategy. Full backups are easy to implement. If you are considering backing up your transaction log as well, test all backup-and-restore procedures intensively.

When choosing your backup strategy, you can use the following methods:

- **Full Backup of Your Data**
  
  In SQL Server, a full backup is a consistent copy of your database at a certain time. Since only used objects are saved, normally the copy is smaller than the original database. Full backups should be scheduled for a time when there is a low load on the database server.

- **Backup of Transaction Log**
The Transaction Log is a serial record of all the transactions that have been performed on the database since the transaction log was last backed up. With transaction log backups, you can recover the database to a specific point in time or to the point of failure.

The transaction log grows over time. If the transaction log exceeds a certain size, it can cause problems in SQL Server. To prevent those problems, we recommend doing regular backups of the transaction log, which truncates the transaction log.

- **Backup of SAP Business One Subdirectories**

  To avoid data loss, you must back up regularly the following subdirectories of SAP Business One:
  
  - `...\Program Files\SAP\SAP Business One\Attachments\`
  - `...\Program Files\SAP\SAP Business One\Bitmaps\`
  - `...\Program Files\SAP\SAP Business One\ExclDocs\`
  - `...\Program Files\SAP\SAP Business One\WordDocs\`

  These directories contain Word and Excel documents and bitmaps. To store the backed up directories, you can use a file archiving application.

  **Recommendation**

  Test your backup and recovery procedures thoroughly. Testing helps to ensure that you have the required backups to recover from various failures, and that your procedures can be executed smoothly and quickly if a failure occurs.

  The frequency of the backups depends on the following factors:

  - Processed data volume
  - Customer requirements
  - Number of users

  Consider how much time you would need to invest in retrieving your data manually after a data loss. After installing or upgrading SAP Business One, perform a full backup of the `SBO_DB` database.

6.1.4.2. **Backup Types**

You can back up your data with SAP Business One Service Manager, the backup functionality of remote support platform for SAP Business One, or SQL Server Management Studio, using one of the backup types described below:

- **Full Backup Using SAP Business One Service Manager**

  This backup type suits small and medium-sized businesses. You can perform only full backups of your application database.

  Advantages include easy setup and restoration, since you have to restore only the full backup.

  Disadvantages include the following:

  - Requires large amount of space
  - Is time consuming
  - Is suitable for backing up once a day, which means that you can lose a whole day’s data.

  For more information, see [Configuring Backup Services](#).
Set **Recovery Model** to the **Simple Model** option. We recommend using the backup service from SAP Business One Service Manager only when performing a simple recovery. Always back up the company database before performing a restore operation; during restore, the database reverts to the state it was in when the backup was created.

- **Full Backup Using SQL Server Management Studio**
  This backup type provides more functionality than the Service Manager and can save the backup directly to tape. If you save the backups on disk, make sure the backup is copied to another medium, such as another hard disc, DVD, or tape.

  Do a manual backup of the files and directories of your hard disk.

- **Full Backup and Transaction Log Backup Using SQL Server Management Studio**

  **Note**
  To use SQL Server Management Studio to perform transaction log backups, you should have already selected the **Full recovery model** option.

  The advantage of this type of backup is that the monitoring is partly automated and you can save the backups directly to a tape. You can also add alerts. Disadvantages include a relatively complicated setup and the need to manually back up the subdirectories of SAP Business One. However, SAP Business One does not fully support all of the features available with SQL Server Management Studio; therefore, if you require support from SAP in the future, your database backup may not be fully compatible.

  **Note**
  - Full Recovery - you can perform accumulated backups and move back to a specific point in time.
  - Simple Recovery - you can only back up the whole database; after the restoration, the database goes back to exactly the same point at which it was backed up.

  **CAUTION**
  SAP Business One backup service does not support a full recovery with its extra features, only the simple recovery. If you manage the backup for the database without the SAP Business One backup service, you can use the full recovery. But if any database issue requires investigation, SAP support might not be able to use these backups, because they were not generated with simple recovery mode and they might contain only the newly added data and not the full backup.

  **Example**
  The following table summarizes the main options for each backup type:

<table>
<thead>
<tr>
<th>Backup Type</th>
<th>Only Full Backup</th>
<th>Full Backup</th>
<th>Full Backup and Transaction Log Backup</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tool</td>
<td>SAP Business One Service Manager</td>
<td>Microsoft SQL Server Management Studio</td>
<td>Microsoft SQL Server Management Studio</td>
</tr>
<tr>
<td>Recovery model</td>
<td>Simple</td>
<td>Simple</td>
<td>Full</td>
</tr>
<tr>
<td>Installation effort</td>
<td>Low</td>
<td>Medium</td>
<td>High</td>
</tr>
</tbody>
</table>
## Backup Type

<table>
<thead>
<tr>
<th>Backup Type</th>
<th>Only Full Backup</th>
<th>Full Backup</th>
<th>Full Backup and Transaction Log Backup</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monitoring effort</td>
<td>Medium</td>
<td>Medium</td>
<td>Medium</td>
</tr>
<tr>
<td>Backup destination</td>
<td>Disk</td>
<td>Disk or Tape</td>
<td>Tape or disk</td>
</tr>
<tr>
<td>Automatic file backup</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Complexity</td>
<td>Low</td>
<td>Medium</td>
<td>High</td>
</tr>
</tbody>
</table>

### Note

SAP Business One Product Support only accepts backups on destination disks. If you back up on tape, you must first restore it from there, and back it up again, using a destination disk, prior to sending it to SAP Support.

## 6.1.4.3. Troubleshooting Backups

To ensure that your database backups are successful, check your server at regular intervals. Ensure that you have enough disk space on the server on which your database is stored. If you store your backup on another server, check that there is enough free space.

The basic checks include:

- Drive space
- Disk subsystem errors
- Tape drive errors
- Event Viewer
- Regular evaluation of your recovery and restore process

### Procedure

1. To check the disk space, proceed as follows:
   b. Check the free space on your hard disk.
      The free space you need on your hard disk depends on the volume of data you process each day.
      Depending on the disk system and the tape drive, scan for disk errors at regular intervals. For more information, see your tape drive documentation.

2. To check if errors occurred in the operating system or in the database server, proceed as follows:
      - Events that occur in the system are stored in three different logs. Within these logs, events are classified as type: Information, Warning, or Error.
Events that occur within the database server are stored in the Application folder. In the Source column of the application log, you can see the source application for a specific event.

b. Double-click an event to display more information.

c. In the Application Log, look for error events that may indicate backup failures.

If you perform network backups, look for network errors in the System and Application logs.

### 6.1.5. Restore

If a failure damages the system, restoring the database restores the integrity of the data in most cases. Ideally, the downtime of the system will be minimal and no data should be lost. Develop a restore strategy that considers the maximum downtime allowed for your system, and estimate how much time you need to react to a system failure. Analyze the problem and take appropriate measures.

You may be required to change hardware or reinstall the operating system before restoring your database.

Ensure that an employee familiar with the restore procedures is available at all times. Testing of the restore procedures improves the chances of a successful and fast recovery of your data. We recommend doing test backups and test restores at regular intervals.

Restore the database in the following situations:

- Hardware failure
- Migration to a new hardware
- Logical errors
- Virus
- Testing

#### 6.1.5.1. Restore Checklist

The steps below comprise a general procedure for restoring data. You may find that you do not need to perform each step for your particular case.

1. Analyze the problem.
2. If possible, save the current active transaction log.

**Note**

If the database fails, but SQL Server is still available, the transaction log contains data that has not been saved yet. You can save it only if the following are not damaged:

- Hard disk on which the transaction log is saved
- Hard disk on which the executable files are located

If you cannot save the transaction log, you can only restore the changes that occurred after the backup of the last transaction log.

3. Use the necessary hardware.
4. Configure your database server.
5. Restore your last full backup.
6. Restore the transaction log.
7. Test all executed measures.
8. Release to productive operation.

6.1.5.2. Saving the Current Transaction Log

**CAUTION**
Before you start the restore process, verify that the installed service pack has not changed since the time of the backup.

**Procedure**

1. Insert a new tape and, to open SQL Server Management Studio, choose **Start → All Programs → Microsoft SQL Server 2005 or Microsoft SQL Server 2008 → SQL Server Management Studio.**

2. Select the relevant database, right-click it, and choose the **New Query** menu.

3. In the **Query** window, run the following command:
   
   ```sql
   BACKUP LOG <sid> TO <tape> WITH NO_TRUNCATE, FORMAT
   
   Where:
   <sid> = name of the database, for example, sbodemo_us
   <tape> = your backup tape name (case sensitive)
   ```

4. After saving the transaction log file, you can change any damaged hardware and, if necessary, reinstall your operating system and your SQL Server database, as described in **Installing SAP Business One.**

5. Restore your last full database backup.
   The database is now in the same condition as it was when the backup was carried out. After you restore the transaction logs, finished transactions are applied to the database again.

6. Perform a rollforward until the end of the transaction log.
   The database is now in the same condition as it was at the time of the last transaction log backup. As this condition is not consistent, perform a rollback for all unfinished transactions.

   The `<msdb>` database stores the history of backups and of restore operations in the backup set and backup file of the tables. If the `<msdb>` database is available, the recovery is based on the saved history in `<msdb>`. For information, see **Restoring Data When msdb Is Available.**

   If the system database `<msdb>` is not available, you have to restore it and reconstruct the history. For information, see **Restoring Data When msdb Is Unavailable.**

**Recommendation**
To ensure a successful restore operation, you can test the restore process against a test database. If you use the transaction log file, we recommend testing all procedures thoroughly.
6.1.5.3. Restoring Backup Files and Application Folders

To restore backup files and application folders, perform the following procedures:

1. Extract the files from the backup archive, including:
   - Database backup .zip file
   - Application folder backup archive files
2. Extract the application folder backup archive files to separate folders.
3. Manually copy the extracted files back to the original shared folders.

6.1.5.4. Restoring Data When msdb Is Available

This procedure provides instructions for restoring your database when the database `msdb` is available. When you use the history function, the last backups are selected automatically.

Procedure

1. To enable the system to restore the database, close SAP Business One.
2. To launch SQL Server Management Studio, choose `Start` → `All Programs` → `Microsoft SQL Server 2005` or `Microsoft SQL Server 2008` → `SQL Server Management Studio`.
3. Right-click the required database and choose `Tasks` → `Restore` → `Database`.
   
   A list of performed backups appears. The last full backup and the subsequent transaction log backups are selected automatically.
4. In the `Restore Database` window, on the `Options` tab, select the following options:
   - `Overwrite over existing database`
     
     To overwrite the existing database, select this option.
   - `Preserve the replication settings`
   - `Prompt before restoring each backup`
     
     Prompt the user before restoring each backup to prevent a user from inadvertently restoring a backup.
   - `Restrict access to the restored database`
   - `Restore database file as`
     
     In the `Restore As` column, change the path name if you are restoring the database on a different server.

**Note**

To specify the `.bu` file, do the following:

1. In the `Microsoft SQL Server Management Studio` window, in the `General` tab, select the `From Device` radio button and choose the `Browse` button.
2. In the `Specify Backup` window, choose the `Add` button.
3. In the `Locate Backup File <computer_name>` window, in the `Files of Type` dropdown list, select `All Files`.
4. In the hierarchy tree, specify the `.bu` file that you want to restore.
5. Choose the `OK` button.
5. To confirm, choose the OK button. The system starts the database restore process.

6. Wait until the following message is displayed:

   Restore of Database <databasename> completed successfully.

SQL Server copies the data from the backups, restoring the database and creating all dependent files.

### 6.1.5.5. Restoring Data When msdb Is Unavailable

This section provides instructions for restoring your database when the history in the database `<msdb>` is not available, for example, after you reinstall SQL Server. For this procedure, you need your last full backup and all subsequent backups of the transaction log.

**Procedure**

1. To enable the system to restore the database, close SAP Business One.

2. To launch SQL Server Management Studio, choose Start → All Programs → Microsoft SQL Server 2005 or Microsoft SQL Server 2008 → SQL Server Management Studio.

3. Create a new database as follows:
   a. Right-click the Databases folder and choose Tasks → Restore → Database. The Restore Database window appears.
   b. Specify a name for your new database (the name of your company in SAP Business One).

4. Right-click the new database and choose Tasks → Restore → Database.

5. Select the Restore: From Device option and choose the Browse button.

6. In the Specify Backup window, choose the Add button.

7. In the Locate Backup File window, locate and select the file containing your last full backup. Choose the OK button.

8. In the Specify Backup window that opens, locate and select the file containing your last full backup. Choose the OK button.

9. In the Restore Database window, select the required back sets and on the Options tab make the following settings:
   - Select the Overwrite the existing database checkbox.
   - Under the Restore As column, change the path, if necessary, for example, if you are restoring the database on a different server where the path name does not exist.
   - In the Recovery completion state area, select the descriptor Leave database non-operational but able to restore additional transaction logs. Choose the OK button. The system starts restoring the database.

10. Wait for the following message:

    Restore of Database <sid> completed successfully.

    Continue to the procedure for restoring transaction logs.
Restoring Transaction Logs

Procedure

1. Right-click the database you want to restore and choose Task → Restore → Transaction Log.
2. Select the Restore: From Device option and choose the Browse button.
3. In the Specify Backup window, choose the Add button.
4. In the Locate Backup File window that appears, locate and select the file containing your last full backup.
   Choose the OK button, and do the same in the Specify Backup window that opens.
5. In the Restore Database window, on the Options tab, make the following settings:
   - Select Overwrite the existing database.
   - In the Recovery completion state area, choose the option Leave database not operational but able to restore additional transaction logs.
   - Choose the OK button.
   The system starts to restore the database.
6. Repeat this procedure for all transaction logs.

When you reach the last transaction log, in the Recovery Completion State pane, select the option: Leave database operational. No additional transaction log can be restored.

6.1.5.6. Troubleshooting Restore

The only way to verify that you can do so is to regularly restore backups using the same medium that you would use in disaster recovery.

**Recommendation**

At regular intervals, perform the procedures that would take place in case of a disaster, including the restore process of full and transaction log backups.

6.2. Data Transfer Workbench for SAP Business One

SAP Business One implementations require you to move data from legacy systems to the new SAP Business One system. Business data (such as customers, vendors, and products) must be available in the new system before it goes live.

Data Transfer Workbench provides a wizard that imports new data into SAP Business One and updates existing data. To simplify the preparation of data for the import, SAP provides predefined data file templates. Data Transfer Workbench records import activities so you can track the data migration process.

For more information, see the Data Transfer Workbench online help file in the document resource center at [http://service.sap.com/smb/sbocustomer/documentation](http://service.sap.com/smb/sbocustomer/documentation).

The data migration process comprises the following tasks:

1. Extracting data files from your legacy system
2. Cleaning data
3. Mapping data and converting data
4. Importing data into SAP Business One
5. Checking the results of the import

### 6.3. Stored Procedures

The stored procedures listed below are all used in the SAP Business One 8.81 application. The first table is for the **SBO-COMMON** database and the second one is for the company database.

**CAUTION**

You must not rename or remove any of the items in the list; otherwise, errors could occur when running SAP Business One.

#### SBO-COMMON Database Procedures

<table>
<thead>
<tr>
<th><strong>SBO-COMMON Procedures</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>ClearEnumValues</td>
</tr>
<tr>
<td>DeleteAllEnumsAndClasses</td>
</tr>
<tr>
<td>DeleteAllObjects</td>
</tr>
<tr>
<td>DeleteAllPropertyDefs</td>
</tr>
<tr>
<td>DeleteClassDef</td>
</tr>
<tr>
<td>DeleteDependentProperties</td>
</tr>
<tr>
<td>DeleteEnumType</td>
</tr>
<tr>
<td>DeleteMetaObject</td>
</tr>
<tr>
<td>DeleteMetaProperty</td>
</tr>
<tr>
<td>DeleteMetaRelation</td>
</tr>
<tr>
<td>DeletePropertyDef</td>
</tr>
<tr>
<td>InsertClassDef</td>
</tr>
<tr>
<td>InsertClassDefId</td>
</tr>
<tr>
<td>InsertEnumType</td>
</tr>
<tr>
<td>InsertEnumTypeId</td>
</tr>
<tr>
<td>InsertEnumValue</td>
</tr>
<tr>
<td>InsertMetaObject</td>
</tr>
<tr>
<td>InsertMetaProperty</td>
</tr>
<tr>
<td>InsertMetaRelation</td>
</tr>
<tr>
<td>InsertPropertyDef</td>
</tr>
<tr>
<td>InsertPropertyDefId</td>
</tr>
<tr>
<td>NumberPropertyDefs</td>
</tr>
<tr>
<td>NumberRelations</td>
</tr>
<tr>
<td>SBO- COMMON Procedures</td>
</tr>
<tr>
<td>----------------------------------------</td>
</tr>
<tr>
<td>OBSSp_GetNextExecFromSchedule</td>
</tr>
<tr>
<td>OBSSp_GetServiceRecord</td>
</tr>
<tr>
<td>OBSSp_UpdateScheduleRecord</td>
</tr>
<tr>
<td>OBSSp_UpdateServiceExec</td>
</tr>
<tr>
<td>RGSp_UpdateInstance</td>
</tr>
<tr>
<td>RGSp_UpdateLicense</td>
</tr>
<tr>
<td>TmSp_AliasUpdate</td>
</tr>
<tr>
<td>TmSP_CheckDiskSpace</td>
</tr>
<tr>
<td>TmSp_CopyCompany</td>
</tr>
<tr>
<td>TmSp_GetCompList</td>
</tr>
<tr>
<td>TmSP_GetDbSizeByDrives</td>
</tr>
<tr>
<td>TmSp_GetServerTime</td>
</tr>
<tr>
<td>TmSp_GetUsers</td>
</tr>
<tr>
<td>TmSp_Installer_CreateTmSp</td>
</tr>
<tr>
<td>TmSp_Installer_SetFieldValue</td>
</tr>
<tr>
<td>TmSp_RefreshCompList</td>
</tr>
<tr>
<td>TmSp_RestoreCompany</td>
</tr>
<tr>
<td>UpdateClassDef</td>
</tr>
<tr>
<td>UpdateEnumType</td>
</tr>
<tr>
<td>UpdateMetaObject</td>
</tr>
<tr>
<td>UpdateMetaProperty</td>
</tr>
<tr>
<td>UpdateMetaRelationSeqNo</td>
</tr>
<tr>
<td>UpdatePropertyDef</td>
</tr>
<tr>
<td>UpdatePropertyDefSeqNo</td>
</tr>
<tr>
<td>ClearEnumValues</td>
</tr>
<tr>
<td>DeleteAllEnumsAndClasses</td>
</tr>
<tr>
<td>DeleteAllObjects</td>
</tr>
<tr>
<td>DeleteAllPropertyDefs</td>
</tr>
<tr>
<td>DeleteClassDef</td>
</tr>
<tr>
<td>DeleteDependentProperties</td>
</tr>
<tr>
<td>DeleteEnumType</td>
</tr>
<tr>
<td>DeleteMetaObject</td>
</tr>
</tbody>
</table>
### SBO- COMMON Procedures

<table>
<thead>
<tr>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>DeleteMetaProperty</td>
</tr>
<tr>
<td>DeleteMetaRelation</td>
</tr>
<tr>
<td>DeletePropertyDef</td>
</tr>
<tr>
<td>InsertClassDef</td>
</tr>
</tbody>
</table>

### Company Database Procedures

<table>
<thead>
<tr>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>_TmSp_AliasUpdate_OUSR</td>
</tr>
<tr>
<td>_TmSp_AliasUpdateAfter</td>
</tr>
<tr>
<td>_TmSp_AliasUpdateBefore</td>
</tr>
<tr>
<td>_TmSp_ControlAccountUpgrade_OCRD</td>
</tr>
<tr>
<td>_TmSp_ConvertGrpLine_OACT</td>
</tr>
<tr>
<td>_TmSp_ExpnsUpdateOnDocs</td>
</tr>
<tr>
<td>_TmSp_FormattedSearchUpdate</td>
</tr>
<tr>
<td>_TmSp_MthDate_Update_JDT1</td>
</tr>
<tr>
<td>_TmSp_RestorelsCommited_OIBT</td>
</tr>
<tr>
<td>_TmSp_SetCategoryAtOFPR</td>
</tr>
<tr>
<td>_TmSp_SetLineNumAtADO3</td>
</tr>
<tr>
<td>_TmSp_SetLineNumAtDOC3</td>
</tr>
<tr>
<td>_TmSp_SetLineNumAtDOC5</td>
</tr>
<tr>
<td>_TmSp_SetLineSeqAtDOC4</td>
</tr>
<tr>
<td>_TmSp_SetLineSeqAtPMN5</td>
</tr>
<tr>
<td>_TmSp_SetUniqueDocEntryAtOCRD</td>
</tr>
<tr>
<td>_TmSp_ShekelUpdate</td>
</tr>
<tr>
<td>_TmSp_UpdateCreateDateOnOINM</td>
</tr>
<tr>
<td>_TmSp_UpdateDoubleName</td>
</tr>
<tr>
<td>_TmSp_VariableUpdate_OUQR</td>
</tr>
<tr>
<td>_TmSp_VatSumCalc</td>
</tr>
<tr>
<td>SBO_SP_PostTransactionNotice</td>
</tr>
<tr>
<td>SBO_SP_PostTransactionSupport</td>
</tr>
<tr>
<td>SBO_SP_TransactionNotification</td>
</tr>
<tr>
<td>SBO_SP_TransactionSupport</td>
</tr>
</tbody>
</table>
### Company Database Procedures

- TmSp_adding_To_OITW
- TmSp_AddSqlUser
- TmSp_ChooSeCIN4Correction
- TmSp_ChooSeINV4Correction
- TmSp_ConGrpLine_OACT_recurs
- TmSp_ConvertGrpLine_OACT
- TmSp_CorrActReport
- TmSp_CorrActReport_BP
- TmSp_CorrActReport_BP_Split
- TmSp_CorrActReport_Split
- TmSp_DragOn
- TmSp_DragOnPk
- TmSp_FifoGetINM_Records
- TmSp_GetDocVatTotals
- TmSp_GetMaxRange
- TmSp_GetOpenRCTs
- TmSp_GetOpenRIINs
- TmSp_GetUsers
- TmSp_GetWDD
- TmSp_Installer_SetFieldValue
- TmSp_OpportAnalysis
- TmSp_OpportAnalysis_CRD
- TmSp_OpportAnalysis_ITM
- TmSp_OpportAnalysis_SLP
- TmSp_OutboxSync
- TmSp_PicknPackCreateTempTable
- TmSp_Purch_An_Crd_Det_Y
- TmSp_Purch_An_Crd_Grp_M
- TmSp_Purch_An_Crd_Grp_Y
- TmSp_Purch_An_Crd_Sng_M
- TmSp_Purch_An_Crd_Sng_Y
- TmSp_Purch_An_Ilm_Det_Y
<table>
<thead>
<tr>
<th>Company Database Procedures</th>
</tr>
</thead>
<tbody>
<tr>
<td>TmSp_Purch_An_Itm_Grp_M</td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Grp_Y</td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Sng_M</td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Sng_Y</td>
</tr>
<tr>
<td>TmSp_Purch_An_Slp_Sng_M</td>
</tr>
<tr>
<td>TmSp_Purch_An_Slp_Sng_Y</td>
</tr>
<tr>
<td>TmSp_RebuildAcctMatch</td>
</tr>
<tr>
<td>TmSp_RebuildMatchHistory</td>
</tr>
<tr>
<td>TmSp_Replace_Table</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Det_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Grp_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Grp_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Sng_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Sng_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Itm_Det_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Itm_Grp_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Itm_Grp_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Itm_Sng_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Itm_Sng_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Slp_Sng_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Slp_Sng_Y</td>
</tr>
<tr>
<td>TmSp_SetBalanceByJdt</td>
</tr>
<tr>
<td>TmSp_SetBgtAccumulators_ByJdt</td>
</tr>
<tr>
<td>TmSp_SetGlStamp</td>
</tr>
<tr>
<td>TmSp_SetVendorDeductPercent</td>
</tr>
<tr>
<td>_TmSp_AliasUpdate_OUSR</td>
</tr>
<tr>
<td>_TmSp_AliasUpdateAfter</td>
</tr>
<tr>
<td>_TmSp_AliasUpdateBefore</td>
</tr>
<tr>
<td>_TmSp_ControlAccountUpgrade_OCRD</td>
</tr>
<tr>
<td>_TmSp_ConvertGrpLine_OACT</td>
</tr>
<tr>
<td>_TmSp_ExpnsUpdateOnDocs</td>
</tr>
<tr>
<td>_TmSp_FormattedSearchUpdate</td>
</tr>
</tbody>
</table>
### Company Database Procedures

<table>
<thead>
<tr>
<th>Procedure Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>_TmSp_MthDate_Update_JDT1</td>
<td></td>
</tr>
<tr>
<td>_TmSp_RestoreIsCommited_OIBT</td>
<td></td>
</tr>
<tr>
<td>_TmSp_SetCategoryAtOFPR</td>
<td></td>
</tr>
<tr>
<td>_TmSp_SetLineNumAtADO3</td>
<td></td>
</tr>
<tr>
<td>_TmSp_SetLineNumAtDOC3</td>
<td></td>
</tr>
<tr>
<td>_TmSp_SetLineNumAtDOC5</td>
<td></td>
</tr>
<tr>
<td>_TmSp_SetLineSeqAtDOC4</td>
<td></td>
</tr>
<tr>
<td>_TmSp_SetLineSeqAtPMN5</td>
<td></td>
</tr>
<tr>
<td>_TmSp_SetUniqueDocEntryAtOCR</td>
<td></td>
</tr>
<tr>
<td>_TmSp_ShekelUpdate</td>
<td></td>
</tr>
<tr>
<td>_TmSp_UpdateCreateDateOnOINM</td>
<td></td>
</tr>
<tr>
<td>_TmSp_UpdateDoubleName</td>
<td></td>
</tr>
<tr>
<td>_TmSp_VariableUpdate_OUQR</td>
<td></td>
</tr>
<tr>
<td>_TmSp_VatSumCalc</td>
<td></td>
</tr>
<tr>
<td>SBO_SP_PostTransactionNotice</td>
<td></td>
</tr>
<tr>
<td>SBO_SP_PostTransactionSupport</td>
<td></td>
</tr>
<tr>
<td>SBO_SP_TransactionNotification</td>
<td></td>
</tr>
<tr>
<td>SBO_SP_TransactionSupport</td>
<td></td>
</tr>
<tr>
<td>TmSp_adding_To_OITW</td>
<td></td>
</tr>
<tr>
<td>TmSp_AddSqlUser</td>
<td></td>
</tr>
<tr>
<td>TmSp_ChooseCIN4Correction</td>
<td></td>
</tr>
<tr>
<td>TmSp_ChooseINV4Correction</td>
<td></td>
</tr>
<tr>
<td>TmSp_ConGrpLine_OACT_recur</td>
<td></td>
</tr>
<tr>
<td>TmSp_ConvGrpLine_OACT</td>
<td></td>
</tr>
<tr>
<td>TmSp_CorrActReport</td>
<td></td>
</tr>
<tr>
<td>TmSp_CorrActReport_BP</td>
<td></td>
</tr>
<tr>
<td>TmSp_CorrActReport_BP_Split</td>
<td></td>
</tr>
<tr>
<td>TmSp_CorrActReport_Split</td>
<td></td>
</tr>
<tr>
<td>TmSp_DragOn</td>
<td></td>
</tr>
<tr>
<td>TmSp_DragOnPk</td>
<td></td>
</tr>
<tr>
<td>TmSp_FifoGetINM_Records</td>
<td></td>
</tr>
<tr>
<td>TmSp_GetDocVatTotals</td>
<td></td>
</tr>
<tr>
<td>Company Database Procedures</td>
<td></td>
</tr>
<tr>
<td>----------------------------</td>
<td></td>
</tr>
<tr>
<td>TmSp_GetMaxRange</td>
<td></td>
</tr>
<tr>
<td>TmSp_GetOpenRCTs</td>
<td></td>
</tr>
<tr>
<td>TmSp_GetOpenRINs</td>
<td></td>
</tr>
<tr>
<td>TmSp_GetUsers</td>
<td></td>
</tr>
<tr>
<td>TmSp_GetWDD</td>
<td></td>
</tr>
<tr>
<td>TmSp_Installer_SetFieldValue</td>
<td></td>
</tr>
<tr>
<td>TmSp_OpportAnalysis</td>
<td></td>
</tr>
<tr>
<td>TmSp_OpportAnalysis_CRD</td>
<td></td>
</tr>
<tr>
<td>TmSp_OpportAnalysis_ITM</td>
<td></td>
</tr>
<tr>
<td>TmSp_OpportAnalysis_SLP</td>
<td></td>
</tr>
<tr>
<td>TmSp_OutboxSync</td>
<td></td>
</tr>
<tr>
<td>TmSp_PicknPackCreateTempTable</td>
<td></td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Det_Y</td>
<td></td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Grp_M</td>
<td></td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Grp_Y</td>
<td></td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Sng_M</td>
<td></td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Sng_Y</td>
<td></td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Det_Y</td>
<td></td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Grp_M</td>
<td></td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Grp_Y</td>
<td></td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Sng_M</td>
<td></td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Sng_Y</td>
<td></td>
</tr>
<tr>
<td>TmSp_Purch_An_Slp_Sng_M</td>
<td></td>
</tr>
<tr>
<td>TmSp_Purch_An_Slp_Sng_Y</td>
<td></td>
</tr>
<tr>
<td>TmSp_RebuildAcctMatch</td>
<td></td>
</tr>
<tr>
<td>TmSp_RebuildMatchHistory</td>
<td></td>
</tr>
<tr>
<td>TmSp_Replace_Table</td>
<td></td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Det_Y</td>
<td></td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Grp_M</td>
<td></td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Grp_Y</td>
<td></td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Sng_M</td>
<td></td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Sng_Y</td>
<td></td>
</tr>
</tbody>
</table>
Company Database Procedures

<table>
<thead>
<tr>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>TmSp_Sales_An_Itm_Det_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Itm_Grp_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Itm_Grp_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Itm_Sng_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Itm_Sng_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Slp_Sng_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Slp_Sng_Y</td>
</tr>
<tr>
<td>TmSp_SetBalanceByJdt</td>
</tr>
<tr>
<td>TmSp_SetBgtAccumulators_ByJdt</td>
</tr>
<tr>
<td>TmSp_SetGlStamp</td>
</tr>
<tr>
<td>TmSp_SetVendorDeductPercent</td>
</tr>
<tr>
<td>TmSp_UpdatingOIT</td>
</tr>
</tbody>
</table>

### 6.4. Getting Support

We recommend that you assign a contact person who can deal with issues concerning SAP Business One. This contact person should follow the support process described below. If a problem cannot be solved using this process, contact SAP support.

![Note]

Before you contact SAP support, check the version information of your SAP Business One application.

To view the version number, from the SAP Business One Help menu, choose About.

You can get support from your partner using either the Customer Portal or the Hotline.

The Hotline is a number provided by your partner that you can call to get support during official support hours. The partner support staff logs the problem on SAP Service Marketplace. The partner support staff try to solve your problem. If they are unsuccessful, they forward the problem to the SAP Support team.

![Recommendation]

You can log your problem message in SAP Business One Customer Portal at [http://service.sap.com/smb/sbocustomer/documentation](http://service.sap.com/smb/sbocustomer/documentation). This lets you track the status of the message. Your SAP Business One partner can provide a user name for this portal. There you can find more information about how to create a message and track its status.
6.4.1. Using Online Help and SAP Notes

If you have a question or problem concerning SAP Business One, check the online help. If that does not provide an answer, search for corresponding SAP Notes, as follows:

**Procedure**

1. Log on to the SAP Business One portal as follows:
   - If you are a partner, log on to [https://service.sap.com/smb/sbosupport](https://service.sap.com/smb/sbosupport).
   - If you are a customer, log on to [https://service.sap.com/smb/sbocustomer](https://service.sap.com/smb/sbocustomer).

2. Choose the SAP Notes option.
   
   You can either display a Note directly by providing the number of the Note, or you can search for a Note by entering key words. Think about the keywords to use, and choose the application area.

   The application area for SAP Business One starts with “SBO”.

   **Recommendation**

   The following example illustrates the difference between a usable and an unusable search.

   **Problem Message**

   “The performance of the SAP Business One program is not acceptable. Executing all operations takes a long time. The problem occurs only on one front-end.”

   **Use:** Key words *Performance* and *SAP Business One*. Specify the component SBO-BC*

   **Do not use:** Phrases such as *SAP Business One runs long* or *SAP Business One is too slow*.

6.4.2. Using the Support Desk

You can use the support desk to search for known solutions in the SAP support database on SAP Service Marketplace. The support desk establishes a direct link to SAP Service Marketplace, which stores all the known solutions to known problems.

For more information, see the online help for SAP Business One on the SAP Business One product DVD or in the documentation area of SAP Business One Customer Portal at [https://service.sap.com/smb/sbocustomer/documentation](https://service.sap.com/smb/sbocustomer/documentation).

**Prerequisites**

You have a valid $ user ID number.

An $ user has authorization to access online support functions offered by SAP. The $ user ID information is shipped with the SAP Business One product. If this information is missing or incorrect, contact your SAP Business One partner.

**Procedure**

To find solutions on SAP Service Marketplace, proceed as follows:

1. From the SAP Business One menu bar, choose Help → Support Desk → Find a Solution.
   
   The Support Desk – Find a Solution window appears.

2. In the Search Term field, enter one or more words for which to search.
   
   You can search for key words or phrases of up to 60 characters.
3. Choose the *Find* button.
   The system calls up the connection to SAP Service Marketplace.

4. Specify your *S-user ID* and password.
   The system defaults your search criteria and the application area to *SBO* and starts the search.
7. Managing Security in SAP Business One

Your security requirements are not limited to SAP Business One, but apply to your entire system landscape. Therefore, we recommend establishing a security policy that addresses the security issues of the entire company. This section offers several recommendations to help you meet the security demands of SAP Business One.

Your security solution should cover the following aspects:

- **Technical Landscape**: Provides an overview of the technical components and communication paths used in SAP Business One.
- **User Management and Authentication**: Provides system access to legitimate users only and prevents identity impersonation.
- **Database Authentication**: To improve the security of database access, a strong password definition mechanism is introduced.
- **Data Integrity**: To improve data integrity in the database, a new setting is defined to allow specified SAP Business One users to run read-only queries on the company database through SAP Business One's query editors.
- **SAP Business One Authentication and Authorization**: Describes how to restrict access to the SAP Business One database.
- **Network Security**: Supports your communication needs without allowing unauthorized access to your network.
- **Application Security**: Restricts access to users with the necessary permissions.
- **Security Solutions for Microsoft SQL Server and Database Tips**: Provides recommendations for ensuring the security of Microsoft SQL Server.
- **Data Storage Security**: Provides recommendations for secure data storage in SAP Business One.

Once you have established your security policy, we recommend that you dedicate sufficient time and allocate ample resources to implement it and maintain the level of security that you require.

### 7.1. Technical Landscape

Figure 6 below is a representation of the security workflow for SAP Business One.

In SAP Business One 8.81, database credentials are saved in the license server, which serves as the security server.

Database credentials are obtained by supplying SAP Business One logon credentials for authentication against the license server. Upon successful authentication, the connection to the databases can be established using database credentials from the license server.
**7.2. User Management and Authentication**

This subsection provides an overview of how SAP Business One supports an integrated approach to user administration and authentication.

**7.2.1. User Management**

This section provides an overview of user types and user administration within SAP Business One.
7.2.1.1. User Types

It is necessary to specify different security policies for different types of users. For example, your policy may specify that individual users who perform tasks interactively have to change their passwords on a regular basis, but not users who process job runs. Therefore, SAP classifies these types of users in the application as follows:

- Site user:
  This user is automatically defined in SAP Business One. It is not a company user type that can log on to SAP Business One, but serves as site-level authentication for performing the following activities:
  - Creating new companies
  - Installing or upgrading SAP Business One server
  - Importing or exporting the license configuration file
  - Assigning read-only users
  - Configuring security settings on the license server
  - Registering databases on the license server

In SAP Business One, the privileged user types are the following:

- SAP Business One company superusers
  When you create a company, a predefined user named manager exists in the system. Due to the password policy, you must change the password of the manager user at the first logon.
  The responsibilities of a superuser entail:
  - Defining users in companies and setting user permissions
  - Configuring password policy at the company level
  - Upgrading a company

- SAP Business One company regular users
  You can define company regular users according to different business role requirements.
  The responsibilities of a regular user are to perform the relevant business work in the SAP Business One application.
7.2.1.2. User Administration

This section describes how to add, remove, or lock an SAP Business One user in the application.

- To add a user in SAP Business One, proceed as follows:
  a. In the SAP Business One Main Menu, choose Administration → Setup → General → Users.
  b. In the Users - Setup window, click in the toolbar and specify the required user-specific data.
  c. Choose the Update button and then the OK button.

- To remove a user in SAP Business One, proceed as follows:
  a. In the SAP Business One Main Menu, choose Administration → Setup → General → Users.
  b. In the Users - Setup window, in the User Code field, enter an asterisk (*) and in the Choose From List window, select the user you want to delete.
  c. Right-click anywhere in the window and choose Remove.
d. Choose the OK button.

- To lock or unlock a user in SAP Business One, proceed as follows:
  a. In the SAP Business One Main Menu, choose Administration → Setup → General → Users.
  b. In the Users - Setup window, in the User Code field, select the user you want to lock or unlock.

   ![Users - Setup window]

   c. In the Users –Setup window, do the following:
      - To lock a user, select the Locked checkbox.
      - To unlock a user, deselect the Locked checkbox.
7.2.2. User Authentication

As standard practice, SAP Business One and the database authenticate users by their user accounts and passwords.

You can change your password at any time. In addition, the application checks the password validity of each logon attempt according to the selected security level.

If you are required to change your password, the application displays the Password Expiration window. You must change the password to log on.

The new password must comply with the settings of the selected security level, containing at least:

- \( x \) characters
- \( x \) lowercase
- \( x \) uppercase
- \( x \) digits
- \( x \) nonalphanumeric

An example password is displayed.

The application saves passwords in the database in encrypted form. The last \( n \) passwords are also encrypted. When appraising a new password, the application first encrypts it and then compares it with the saved ones.

The password policy defines global guidelines and rules for password settings, such as the following:

- Time interval between password changes
- Required and forbidden letters and characters
- Minimum required number of characters
- Number of logon attempts before the system locks the user account

The password policy improves the security of SAP Business One and enables administrators to apply the required security level for their organization.

Note

Only a superuser can change a security level.

SAP Business One supports the following approaches to raising the security level of user authentication:

- Increase the complexity of the password.
- Increase the frequency of password changes.

For information about how to configure it in SAP Business One, see the online help document: Password Administration. You can find the online help documentation in SAP Channel Partner Portal at [http://channel.sap.com/sbo/documentation](http://channel.sap.com/sbo/documentation).

7.3. Database Authentication

The default user name of the database administrator is sa and it has full authorization. Therefore, you must assign a strong sa password, even on servers that are configured to require Microsoft Windows Authentication. This ensures that a blank or weak sa password is not exposed.

A strong password is the first step to securing your system. A password that can be easily guessed or compromised using a simple dictionary attack makes your system vulnerable. A strong password has the following characteristics:

- Contains alphabetic, numeric, and special characters
- Is at least seven characters in length
- Is NOT a common word or name
- Does NOT contain a name or user name
- Is significantly different from previous passwords

To set the password for the sa logon, proceed as follows:

1. Log on to the server as a Domain or local Windows Administrator.
2. From Microsoft Windows, choose Start → Programs → Microsoft SQL Server 2005 or Microsoft SQL Server 2008 → SQL Server Management Studio. Upon first logon, in the Connect to Server window, enter the server name (if required) and under Authentication, select Windows Authentication.

   ![Note]

   We recommend that you create another super user account with the same authorization as the sa user.

3. In the Object Explorer window, under the SQL Server instance, expand Security → Logins. Right-click sa and choose the Properties menu.
4. On the General page, enter and confirm the new password for the sa login.
5. Choose the OK button and close the SQL Server Management Studio window.

   ![CAUTION]

   To prevent dictionary attacks, you should create a substitute user for sa that can take daily responsibility for the SQL Server database assessment.

   For more information, see Changing the sa Login Password and Creating an Alternative User.

To create a superuser account for maintaining administration tasks for SAP Business One, proceed as follows:

1. From Microsoft Windows, choose Start → Programs → Microsoft SQL Server 2005 or Microsoft SQL Server 2008 → SQL Server Management Studio.
2. In the SQL Server Management Studio Object Explorer window, choose Security → Logins.
3. Right-click the Logins folder and choose New Login. The Login - New window appears.
4. On the General tab, select SQL Server authentication and enter a strong password.

5. On the Server Roles tab, select dbcreator and securityadmin.

6. On the User Mapping tab, select the db.owner role for all SAP Business One databases (SBO-COMMON and all companies), and select the public role for the <msdb> database.

Choose the OK button.

7.4. Data Integrity

To improve data integrity in the database and ensure that no changes to the database are made during the running of the application, a setting is defined to allow specified SAP Business One users to run read-only queries on the company database through SAP Business One's query editors. Queries can be restricted to read-only statements. This means user permissions are read only for SQL executions, and querying the database would be done using a read-only user.

7.4.1. Setting Read-Only User Permissions

To prevent any user with access to the query generator from performing any commands on the SAP Business One company database, you can limit Query Generator to read-only queries. You can use the read-only db user feature to enable it.

Note

Adding read-only users is irreversible. Changing the type of such a user in the database leads to errors in SAP Business One.

To create or maintain read-only user permissions in SAP Business One, proceed as follows:

1. To create a new user in the SQL Server database, choose Start → All Programs → Microsoft SQL Server 2005 or Microsoft SQL Server 2008.

   In the Connect to Server window, specify values in the Server name and Authentication fields, and then choose the Connect button.

   o In Microsoft SQL Server Management Studio, choose Security → Login, right-click the Login folder and choose New Login.

   o In the Login-New window, on the General tab, specify a name for the read-only user you want for the SQL Server database.

   o On the User Mapping tab, do the following:

     a. In the Users mapped to this login table area, select the Map checkbox for SBO-COMMON and the company databases.

     b. In the Database role membership for: SBO-COMMON table, select the following checkboxes:

        ▪ db_datareader

        ▪ db_denydatawriter

    CAUTION

    If you select the db_writer checkbox, you then cannot set a read-only user in SAP Business One.

     c. In the Users mapped to this login table area, select the company database that you want to assign the read-only user and perform step b again.
The read-only user can only be applied to new companies that are created later on.

2. Log on to SAP Business One with a super user.

3. To access the Read-Only DB User window, in the SAP Business One Main Menu, choose Administration → Setup → General → Security → Read-Only DB User.

4. In the Site User Logon window, specify the site user password and choose the OK button.

5. In the Read-Only DB User window, specify values in the DB User ID and DB Password fields.

6. Choose the Update button, and then choose the OK button.

7. To set the permission, choose Administration → System Initialization → Authorizations → General Authorizations.
8. In the **Authorizations** window, do the following:
   a. Choose **Reports** → **Query Generator** → **Execute Non-select SQL Statement**.
   b. In the **Authorization** dropdown list, choose **No Authorization** for the read-only user.
7.4.2. Registering New Databases in SAP Business One

For databases to appear on the logon screen of the application, they must be registered with SAP Business One. You can register databases only from the license server.

⚠️ CAUTION

The license server should not be accessible physically to any users except the people who own the site user password.

Keep the license server computer in a place not easily accessed by anyone.

To register new databases, proceed as follows:

1. To open SAP Business One Service Manager, choose Start → All Programs → SAP Business One → Server Tools → Service Manager.
   - In the SAP Business One Service Manager window, in the Service dropdown list, select License Manager.
   - Choose the Settings button.

2. In the General Settings window, choose the Configure Security button.
3. In the **Validate Site User Password** window, specify the site user password. Choose the **OK** button.

4. In the **Connection Settings** window, specify the following fields:
   - **DB Type**: From the dropdown list, select your database server type.
   - **DB Server**: Specify the database server name or the IP address of the database server.

   **CAUTION**
   Make sure that the server name does not contain any of the following special characters:
   - &
   - <
   - >
   - "
   - ,
Make sure that you align the computer name with the name format of your license server. To check or correct your computer name, proceed as follows:

i. Choose Start → Control Panel → System.
ii. In the System Properties window, select the Computer Name tab.
iii. In the Computer name field, check the computer name.
iv. To correct the computer name, choose the Change button.
v. In the Computer Name/Domain Changes window, enter a new name for the computer and choose the OK button.

- **DB Username**: Specify the user ID of the database.
- **DB Password**: Specify the password of the database.

Choose the OK button.

![Connection Settings](image)

**CAUTION**

We recommend that you not select the Use Trusted Connection checkbox to use the Microsoft NT authentication, because it is much weaker than SQL Server authentication mode.

Be aware of the following limitations of Windows NT authentication:

- Windows NT-trusted in SAP Business One is a server level configuration: all users on the same SAP Business One server can use NT-trusted to connect to SQL Server if the checkbox is selected.
- You have to maintain each computer to be added to the domain for NT-trusted authentication mode, while SQL Server database authentication shares the database user (such as *sa*) on the same SAP Business One server.

For more information about configuring trusted connections, see Troubleshooting Security.
7.5. SAP Business One Authentication and Authorization

SAP Business One has introduced a mechanism to protect the database from easy changes through direct access.

The advantages of restricting access to the SAP Business One database are:

- End users are not exposed to database credentials and so cannot change the databases directly, which protects the databases from being changed or attacked.
- Database credentials are stored in the license server and end users can access the database only after the application performs a successful site user authentication through the license server.

7.5.1. Restricting Access to the SAP Business One Database

SAP Business One has a function that hides database access credentials from SAP Business One end users.

In SAP Business One 8.81, the license server is the central repository for credentials information, including the database user ID and password (one for all SAP Business One users).

The database credentials are stored safely in the license server, with additional encryption.

The workflow procedure is as follows:

1. Database consumers such as SAP Business One client, DI, and Services have to provide the SAP Business One credentials (SAP Business One user ID and password) to authenticate against the license server.
2. Following successful authentication, the license server supplies its credentials and SAP Business One uses them to connect.

7.6. Network Security

We strongly recommend using SAP Business One in trusted environments only (corporate LAN with firewall protection).

7.6.1. SSL Encryption

To secure the TCP/IP communication channel between the database client and the database server, you can implement SSL encryption. The advantage of applying security communication is that it prevents SAP Business One application data, including the database credentials, from being exposed.

SAP Business One fully supports SQL SSL. We recommend that you implement SSL in SAP Business One without making configuration changes in SAP Business One. For more information, see http://support.microsoft.com/kb/316898 or contact your IT administrator.

Note

Using SSL encryption may degrade network performance. The SSL encryption solution for Microsoft SQL Server requires a certificate, which is time limited and needs yearly renewal.

For information about Microsoft SSL encryption guidelines, see www.msdn.microsoft.com and search for the following topics:

- Net-Library Encryption
- Client Net-Libraries
7.6.2. Communication Channels

TCP provides the communication channels between the following:

- SAP Business One server ⇔ SAP Business One clients
- SAP Business One server ⇔ SAP Business One license server
- SAP Business One server ⇔ the agent of remote support platform for SAP Business One

The default communication port is 1143.

The default port of the SAP Business One license server is 30000 for license communication and 30001 for the license naming service.

7.7. Application Security

SAP Business One provides features to ensure that unauthorized access to the application does not occur.

7.7.1. Password Encryption

In SAP Business One, a strong algorithm is used for data encryption and decryption. The site user ID and password are encrypted and saved on the license server.

\[ \text{Note} \]

You should set a site user password that is at least as strong as that defined in company password policy, and change it frequently.

The site user password can be changed through a License Manager configuration, providing a previous password or authenticating the database credentials to prove that whoever is changing the site password is at least at a database administration level.

To change the site user password, proceed as follows:

1. To open SAP Business One Service Manager, choose Start → All Programs → SAP Business One → Server Tools → Service Manager.
2. In the SAP Business One Service Manager window, in the Service dropdown list, select License Manager. Choose the Settings button.
3. In the General Settings window, choose the Configure Security button.
4. In the Validate Site User Password window, choose the Change Site Password button.

5. In the Change Site Password window, specify the following fields:
   - Current Site Password
   - Enter New Site Password
   - Confirm New Site Password

Choose the OK button.
6. In the displayed dialog window, choose the OK button.

### 7.7.2 B1_SHR Folder Permissions

The SAP Business One server installation process creates the B1_SHR folder, which contains the SAP Business One client setup files.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>User</th>
<th>SBO_SHR Permission</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>User</td>
<td>Read and execute</td>
</tr>
<tr>
<td></td>
<td></td>
<td>List folder contents</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Read</td>
</tr>
</tbody>
</table>

### 7.7.3 Query Generation and the Query Wizard

The query wizard tool is designated for Select sentences only and must not be used for any kind of update operation. In SAP Business One, you can use the read-only user configuration to serve the purpose.

The query generator can run customized queries on the SAP Business One database. To protect your data, we recommend that you make sure users have the appropriate permissions.
If you have to restrict a user from updating the database, use the feature introduced in the section Setting Read-Only User Permission. However, the data results returned by the query generator are not filtered according to the user’s authorization.

Note
The highest level of security is a No Authorization setting for the query generator and the query wizard, which is the default setting.

7.7.4. Add-On Access Protection
When you install an add-on, SAP Business One creates a unique digital signature using the MD5 technique (message-digest algorithm). SAP Business One identifies the add-on by validating its digital signature.

7.7.5. SAP Business One Dashboards
Dashboards are an element of the cockpit, which is delivered as part of SAP Business One. They present an easy-to-understand visualization, such as a bar or pie chart, of transactional data from the SAP Business One database. With SAP Business One, SAP delivers predefined dashboards for financials, sales, and service. In addition, SAP Business One partners and customers can create their own dashboards.

Recommendation
When you receive dashboard content from your partner, we recommend that you copy this content to a computer that has a state-of-the-art virus scanning solution with the most current virus signature database installed and scan the file for infections before uploading it to the server.

7.8. Security Solutions for Microsoft SQL Server and Database Tips
We recommend that you take the following actions to ensure the security of your Microsoft SQL Server.

7.8.1. Upgrading the SQL Server
We recommend upgrading the SQL server to the latest service pack. Furthermore, administrators should regularly consult the SQL Server Security Center at www.microsoft.com.

7.8.2. Steps to Securing Microsoft SQL Server
Since SAP Business One is a two-tier application, much of the application security depends on the database server security and on the authorization mechanism. Be aware that users can access the database using tools other than SAP Business One and, therefore, can modify the logon information. To secure your database, we recommend adhering to Microsoft security guidelines. For more information, see the Microsoft documents at www.microsoft.com.

7.8.3. Revoking Guest Access to the msdb Database
1. To open SQL Server Management Studio, choose Start → All Programs → Microsoft SQL Server 2005 or Microsoft SQL Server 2008.
2. In the Connect to Server window, specify values in the Server name and Authentication fields, and choose the Connect button.


4. In the structure, right-click the Guest user and choose Delete.

7.9. Data Storage Security

The security of the data saved in SAP Business One is generally the responsibility of the database provider and your database administrator. As with your application infrastructure, most of the measures that you should take depend on your strategy and priorities.

There are a few general measures, as well as database-specific measures, that you can take to increase the protection of your data. Details are provided in the following sections:

- Exporting the Configuration File
- Importing the Configuration File
- Configuration Logs and User Settings

7.9.1. Exporting Configuration Files

To secure your data, we recommend that you export your security configuration file right after you finish installing the license server and the SAP Business One server.

The configuration file contains the following important information:

- Site user password
- Database information
- Read-only database user information
- Algorithm information

To export the security configuration file, proceed as follows:

1. To open SAP Business One Service Manager, choose Start → All Programs → SAP Business One → Server Tools → Service Manager.

2. In the SAP Business One Service Manager window, in the Service dropdown list, select License Manager and choose the Settings button.
3. In the General Settings window, choose the Configure Security button.

4. In the Validate Site User Password window, specify the current site user password and choose the OK button.

5. In the Connection Settings window, choose the Export Configuration File button.
In the Browse window, do the following:

- Select a destination folder for saving the file.
- Specify a file name.

Choose the OK button.

6. In the message dialog box, choose the OK button.

**CAUTION**

The site user password is required if you later import the security configuration file to restore the configured security settings. Thus, keep a record of the site user password when you are exporting the configuration file, especially if you want to change the site user password after the configuration file is exported.

### 7.9.2. Importing Configuration Files

If your license server crashes or is corrupted, you must set up a new license server. After the new license server is started up, to restore all the security settings you had before, you can import the security configuration file.

1. To open SAP Business One Service Manager, choose Start → All Programs → SAP Business One → Server Tools → Service Manager.

2. In the SAP Business One Service Manager window, in the Service dropdown list, select License Manager.

Choose the Settings button.
3. In the **General Settings** window, choose the **Configure Security** button.

4. In the **Validate Site User Password** window, specify the current site user password and choose the **OK** button.
5. In the **Connection Settings** window, choose the **Import Configuration File** button.

![Connection Settings](image)

6. In the **Import Security Configuration File** window, do the following:

   - Choose the **Browse** button to navigate to your local file directory where the file is saved.
   - In the **Exporting Site Password** field, specify the site user password you had when the configuration file was exported.

Choose the **OK** button.

![Import Security Configuration File](image)

### 7.9.3. Configuration Logs and User Settings

In SAP Business One, configuration changes are logged in files formatted as: `xxx.pidxxxxx` (xxx after pid can be the date, such as 20100325, so that you can find the latest log file) under `%UserProfile%\Local Settings\Application Data\SAP\SAP Business One\Log\BusinessOne`.

The configuration changes include the following:

- Adding/Removing users
- Changing a user to a superuser / non superuser
- Changing user passwords
- Changing user permissions
- Changing password policy
- Changing company details
Note

To find the logs containing changes to company details, do the following:

i. In the SAP Business One Main Menu, choose Administration → System Initialization → Company Details.

ii. In the menu bar, choose Tools → Change Logs.

However, the following configurations cannot be logged:

- Changing data ownership authorizations
- Changing data ownership exceptions
- Changing license settings
- Setting Read-Only DB users

If you fail to log on to SAP Business One, the log is recorded in the Event Viewer.

As of SAP Business One 2007, any specific user settings are saved in a file named: b1-current-user.xml under C:\Documents and Settings\XXX(user id)\Local Settings\Application Data\SAP\SAP Business One. In this situation, if a user changes his or her settings in SAP Business One, the changes are saved in this folder and do not affect other users' settings.

7.10. Troubleshooting Security

- The NT-trusted support is only for SAP Business One backward compatibility.

To configure NT-trusted, you have to provide Windows credentials, as shown in the screen below.

Make sure of the following prerequisites:

- The Windows user has permission to start the SAP Business One license service.
- The Windows user has been registered in SQL Server.
Make sure that your Microsoft Windows account has rights to log on to the license server, because after the NT-trusted policy is configured, the license server service runs with this NT-trusted account.

To check the configuration of your Microsoft Windows account on the computer where your license server is running, proceed as follows:


b. In the Local Security Policy window, choose Local Policies → User Rights Assignment.

c. In the User Rights Assignment window, select the Log on as a service item and double-click the item.

d. In the Log on as a service Properties window, choose the Add User or Group button.

e. Check if your Microsoft Windows account is in the Enter the object names to select (examples): field, and if not, add it and try again.

- To check or correct your computer name, which is necessary to install Microsoft SQL Server 2005 or 2008, proceed as follows:

  a. Choose Start → Control Panel → System.

  b. In the System Properties window, select the Computer Name tab.

  c. In the Computer name field, check the computer name.

  d. To correct the computer name, choose the Change button.

  e. In the Computer Name/Domain Changes window, specify a new name for the computer and choose the OK button.
Copyrights, Trademarks, and Disclaimers

© Copyright 2011 SAP AG. All rights reserved.

The current version of the copyrights, trademarks, and disclaimers at http://service.sap.com/smb/sbocustomer/documentation is valid for this document.